Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

написать программу в паскаль ABC. Теорема Ферма утверждает, что не существует решения в целых числах уравнения x^n+y^n=z^n при n>2.

10-11 класс

напишите программу, которая проверяла бы это утверждение при заданном n для всех x,y и z меньших 100.

Zanka16 08 дек. 2016 г., 23:03:27 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dimas243
09 дек. 2016 г., 1:29:38 (7 лет назад)

var
  n, x, y, z: integer;
begin
  write('n = ');
  read(n);
  for x := 1 to 10 do
    for y := 1 to 10 do
      for z := 1 to 10 do
        writeln(power(x, n) + power(y, n), ' = ', power(z, n));
end.

Ответить

Другие вопросы из категории

Оочень нужно, пожалуйста=)
нужно сложить

110011,00
101111,01

ПОМОГИТЕ :)

Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый день он увеличивал дневную норму на 10% нормы предыдущего дня. Какой суммарный путь пробежит спортсмен за 7 дней?(ПАСКАЛЬ)

Читайте также

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

Написать Программу в паскале которая посчитала бы 5^123 (это цикл как бы должен быть)

http://primat.org/index/0-128 вот сайт что бы написать программу.

Помогите плиз написать программы на Паскале)))

1.Составьте программу, проверяющую, верно ли
утверждение, что введенное вами целое число является четным.
2.



Вы находитесь на странице вопроса "написать программу в паскаль ABC. Теорема Ферма утверждает, что не существует решения в целых числах уравнения x^n+y^n=z^n при n>2.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.