Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Как известно, на вопрос о том, сколько у него учеников, древнегреческий учёный Пифагор отвечал так: "Половина моих учеников изучает математику,

10-11 класс

четвертая часть изучает природу, седьмая часть проводит время в молчаливом размышлении, остальную часть составляют 3 девы".

Секретарь олимпиады на вопрос: "Сколько зарегистрировано участников олимпиады по информатике?", отвечал подобно Пифагору: "K-тая часть участников начала решать первую задачу, M-тая часть – вторую, а N-тая – третью. В то же время D участников решают проблему: "С чего начать?". Ваша задача определить количество участников олимпиады S или вывести -1, если секретарь ошибся.

Технические условия

Входные данные

В единственной строке через пробел числа K, N, M, D. 1K, N, M, D1000.

Выходные данные

Вывести количество участников олимпиады S, или -1, если секретарь ошибся в своём сообщении.

ParAsuT 31 авг. 2014 г., 2:37:56 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Вика091196
31 авг. 2014 г., 5:35:18 (9 лет назад)

Var
K,M,N,D:integer;
y,x,L,t,p:real;
begin
read(k);read(M);read(n);read(d);
P:=1/k;
L:=1/m;
t:=1/n; 
x:=1-(p+l+t);
if x<0 then begin
y:=D/x;
IF frac(y)=0 then
writeln(Y); end
else writeln('-1');
end.

Ответить

Читайте также

На промышленном предприятии решается вопрос о том, сколько потребуется механиков для работы в ремонтном цехе. Пусть предприятие имеет 10 машин,

требующих ремонта с учетом числа ремонтирующихся. Отказы машин происходят с частотой λ=10 отк/час. Для устранения неисправности механику требуется в среднем =3 мин. Распределение моментов возникновения отказов является пуассоновским, а продолжительность выполнения ремонтных работ распределена экспоненциально. Возможно организовать 4 или 6 рабочих мест в цехе для механиков предприятия. Необходимо выбрать наиболее эффективный вариант обеспечения ремонтного цеха рабочими местами для механиков.

компьютерный вирус А заполняет 1 Гбайт за 1 месяц, вирус В заполняет 1 Гбайт за 2 месяца, вирус С заполняет 1 Гбайт за 3 месяца, вирус D заполняет 1

Гбайт за 6 месяцев. На компе обнаружено сразу 4 вируса. Через какое время на 1 Гбайт памяти не останется области, не заполненной вирусами?
1) четверть месяца
2) половина месяца
3) один месяц
4) два месяца
5) три месяца

Алик, Раиф, Валя и Эльдар соревновались в беге. На вопрос, кто какое место занял, каждый дал ответ. Алик:"Не первое и не последнее". Раиф:"Последним был

Алик"Валя:"Первое". Эльдар:"Последнее".Известно, что трое сказали правду, а один солгал. Кто занял первое место? Кто солгал? Как вы это узнали?

решите задачу.турист идет к озеру. у развилки дороги сидят 2 брата и каждый из них знает,какая дорога ведет к озеру.. на вопросы братья

отвечают только да и нет. один из них всегда говорит правду. другой всегда лжет. все это знает турист. помогите туристу сформулировать такие вопросы чтобы узнать, какая дорога ведет к озеру;

1) 2 вопроса одному из братьев;

2) 1 вопрос одному из братьев.

Помогите ответить на вопросы Почему человек использует таблицы? 1. Таблица удобна при поиске структурированной информации. 2.

Таблица позволяет структурировать информацию.

3. Таблица удобна для обзора большого количества информации, она помогает экономить обозримое пространство.

Вопрос 2: Какие виды таблиц удобны для использования обычным человеком? 1. Таблицы типа «объект-объект».

2. Таблицы типа «объект-свойство»

3. Таблицы типа «двоичные матрицы».

Вопрос 3: Какие виды таблиц удобны для использования компьютером?

1. Таблицы типа «объект-объект».

2. Таблицы типа «объект-свойство»

3. Таблицы типа «двоичные матрицы».

Вопрос 4: Что пишут в строчках таблиц типа «объект - свойства»?

1. Свойства объектов.

2. Названия объектов.

3. Свойства или названия объектов.

Вопрос 5: Что пишут в столбиках таблиц типа «объект - свойства»?

1. Названия объектов.

2. Свойства объектов.

3. Свойства или названия объектов.

Вопрос 6: Что пишут на пересечении строчек и столбиков в таблице типа «объект-объект»?

1. Свойства объектов.

2. Названия объектов.

3. Свойства или названия объектов.



Вы находитесь на странице вопроса "Как известно, на вопрос о том, сколько у него учеников, древнегреческий учёный Пифагор отвечал так: "Половина моих учеников изучает математику,", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.