Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Даны натуральные

10-11 класс

числа m и n.Получить число состоящее из m последних чётных цифр числа n. Написать программу на Паскале только на Паскале.

LubashaPuntova 19 дек. 2016 г., 18:59:16 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nike200013
19 дек. 2016 г., 20:35:34 (7 лет назад)

var i, b, c, n, m: integer;
    a: string;
    d: array [0..50] of integer;
begin
     readln(n, m);
     a := inttostr(n);
     for i := 1 to length(a) do
         if (strtoint(a[i]) mod 2 = 0) then
         begin
              d[c] := strtoint(a[i]);
              c := c + 1;
         end;
     for i := 0 to m - 1 do
 writeln(d[i], ' ');
end.

Так, кажется, только если ввести число больше кол-ва чётный цифр в числе, то будет ошибка, я не знаю, как бороться.

Ответить

Читайте также

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

1.Дано натуральное число:

a) найти произведение цифр числа б) верно ли, что в данном числе нет данной цифры А (цифру А вводить с клавиатуры)
2. Найти все трехзначные числа, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, а при увеличении на 4 делятся на 5.
3.Из данного натурального числа удалить все цифры А (а вводятся с клавиатуры).

Написать программы в паскале и желательно блок-схему, но можно и без нее.
Помогите пожалуйста)

Написать прогу на пвскале 6. Дано натуральное число N (N > 9). Определить количество нулей, идущих подряд в младших

разрядах данного числа. Пример. N = 1020000. Количество нулей равно четырем.



Вы находитесь на странице вопроса "Даны натуральные", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.