Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

введите с клавиатуры одномерный массив D(N), элементами которого являются положительные и отрицательный целые числа. Сформируйте новый массив B(V) из

10-11 класс

положительных элементов и С(М) из отрицательных элементов. В массиве D(V) определите максимум, а в массиве С(М)-минимум.

Simcity55 26 июля 2014 г., 10:10:43 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alla17545
26 июля 2014 г., 11:05:07 (9 лет назад)

program asd;
Var B,C,D:array[1..2500] of integer;
i,max,min,n:integer;
BEGIN
Writeln('Введите размерность одномерного массив D: ');
Readln(n);
max:=D[1];
for i:=1 to n do
begin
Write('Введите D[',i,']: '); Readln(D[i]);
If max<D[i] then max:=D[i];
end;
 Writeln('Максимальный элемент в массиве: ',max);
 Writeln('Положительный массив B из D: ');
 min:=D[1];
 For i:=1 to n do
  begin
  If D[i]>0 then
      B[i]:=D[i];
   If D[i]<0 then
     C[i]:=D[i];
   If min>C[i] then
   min:=C[i];
     Write(B[i]:4);
      end;
 writeln;
  Writeln('Отрицательный массив C из D: ');
 For i:=1 to n do
  begin
 Write(C[i]:4);
 end;
 Writeln();
  Writeln('Минимальный элемент в массиве С: ',min);
END.

Ответить

Другие вопросы из категории

Пожалуйста составьте программу.
1.Напечатайте индексы всех равных элементов произвольного массива A(N;N). 2.В заданном тексте заменить последовательность символов X(I) на A(I), подсчит

ать количество произведенных замен. эти две задачи необходимо решить в турбо паскале

Читайте также

Введите с клавиатуры одномерный массив S(K), элементами которого являются положительные и отрицательные числа. Найдите среднее арифметическое значение

среди последних 9-ти элементов массива, максимум среди первых 5-ти элементов. Замените в массиве все элементы, которые больше найденного среднего арифметического - на максимум.

1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы

каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива. 4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных. 5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных. 6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами. Вывести на экран исходный и новый массив. 7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы. 8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.

определить число элементов массива, больших К. По заданному условию сформировать одномерный массив, вывести на печать и произвести операции по обрабо

тке полученных компонентов массива. Исходными данными являются одномерный массив, элементы которого задаются с помощью датчика случайных чисел от -50 до +50 и целое положительное число К

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.



Вы находитесь на странице вопроса "введите с клавиатуры одномерный массив D(N), элементами которого являются положительные и отрицательный целые числа. Сформируйте новый массив B(V) из", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.