Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

СРОЧНО ПОЖАЛУЙСТА! Помогите решить задание в программе Паскаль. Задание: Вычислите и распечатайте больше из чисел а( вверху 2 ) b ( вверху 3 ) с ( вверху 4

5-9 класс

) пожалуйста!

Asf4481 13 июня 2013 г., 7:33:50 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Epishkina2000
13 июня 2013 г., 9:13:32 (10 лет назад)

var
  a, b, c, a2, b3, c4, max: integer;

begin
  Write('Введите через пробел три целых числа -> ');
  Readln(a, b, c);
  a2 := sqr(a); b3 := b * sqr(b); c4 := sqr(sqr(c));
  if a2 > b3 then
    if a2 > c4 then max := a2 else max := c4
  else
  if b3 > c4 then max := b3 else max := c4;
  Writeln('a^2=', a2, ', b^3=', b3, ', c^4=', c4);
  Writeln('Максимальное из значений равно ', max)
end.

Тестовое решение:
Введите через пробел три целых числа -> 287 86 23
a^2=82369, b^3=636056, c^4=279841
Максимальное из значений равно 636056



+ 0 -
Fjhh
13 июня 2013 г., 11:42:25 (10 лет назад)

Что какое "вверху"? Показатель степени? Задаются a,b,c и надо найти наибольшее из "а квадрат", "b куб" и "c в четверой степени"?

+ 0 -
Nadyushka2004
13 июня 2013 г., 14:34:26 (10 лет назад)

Если честно, я вообще глупая) а объяснить, ну есть допустим число 27 в квадрате, тобишь 2 сверху пишется, так и здесь 2 вверху, 3 и 4, наверное, Вы правы, скорее всего показатель степени.ээ

+ 0 -
Vika123456789001
13 июня 2013 г., 15:38:55 (10 лет назад)

Хорошо.... сейчас решу.

+ 0 -
Nrudjd
13 июня 2013 г., 17:57:53 (10 лет назад)

спасибо большое!

+ 0 -
Froct74
13 июня 2013 г., 19:20:02 (10 лет назад)

кнопочки "спасибо" достаточно)))

Ответить

Другие вопросы из категории

Разгадайте кроссворд "компьютерные объекты"1.Другое название

прикладной программы.2.ИЗОБРАЖЕНИЕ НА ЭКРАНЕ МОНИТОРА ГОТОВОГО К РАБОТЕ
КОМПЬЮТЕРА(ДВА СЛОВА)3.ЕДИНИЦА ИНФОРМАЦИИ,РАВНАЯ ВОСЬМИ БИТАМ.4.ГРУППА
ФАЙЛОВ,ИМЕЮЩАЯ ИМЯ;КОНТЕЙНЕР ДЛЯ ФАЙЛОВ.5.ПРЯМОУГОЛЬНАЯ
ОБЛАСТЬ,ЗАНИМАЕМАЯ НА РАБОЧЕМ СТОЛЕ РАБОТАЮЩЕЙ
ПРОГРАММОЙ6.ФАЙЛ,СОДЕРЖАЩИЙ ДАННЫЕ(РИСУНКИ,ТЕКСТЫ)7

А9,А10 заранее спасибо

Читайте также

Пожалуйста помогите решить задачу: Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и

оканчивающихся на 4. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: сумму всех чисел, кратных 6 и оканчивающихся на 4.

Пример работы программы:

Входные данные Выходные данные

14 168

24

144

22

12

0

1)Информатика-это наука... 2)География-это наука... 3)Фонетика-это раздел науки о... 4)Ботаника-это раздел науки о... 5)Имя

существительное-это самостоятельная часть речи,...

6)Глагаол-это самостоятельная часть речи,...

7)Земледельцы-это люди,...

8)Животноводы-это люди,...

9)Тяжёлая промышленность-это...

10)Лёгкая ромышленность-это...

Ребята пожалуйста помогите решить задание для 6 класса по информатике.

составьте программу которая заполняет массив A состоящая из 20 случайных целых чисел в диапазоне от 1 до 30 и выводит на экран элеме

нты значения которых являются чётными и кратными трём . Пожалуйста помогите решить!!!



Вы находитесь на странице вопроса "СРОЧНО ПОЖАЛУЙСТА! Помогите решить задание в программе Паскаль. Задание: Вычислите и распечатайте больше из чисел а( вверху 2 ) b ( вверху 3 ) с ( вверху 4", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.