Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

мне нужна помощь ещё с одной задачей.

5-9 класс

Нужно на языке программирования в программе Паскаль, создать программу:
Найти произведение, сумму и количество всех отрицательных чисел на отрезке [x;y].

Leonteva86 25 июня 2013 г., 9:16:58 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
MrEpicChat12
25 июня 2013 г., 12:16:11 (10 лет назад)

var
    i, x, y, s, p, k: integer;

begin
    read(x, y);
    p := 1;
    for i := x to y do
    begin
        writeln(i);
        if i < 0 then begin
            k := k + 1;
            s := s + i;
            p := p * i;
            writeln(' K = ', k, ' S = ', s, ' P = ', p);
        end;
    end;
    writeln(' K = ', k, ' S = ', s, ' P = ', p);
end.

Ответить

Другие вопросы из категории

1. В массиве Day хранятся данные о количестве израсходованных денег за телефон за неделю (Day [1] — данные за понедельник, Day [2] — за вторник и

т.д.). Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на трех алгоритмических языках.

Алгоритмический язык алг нач целтаб Day[1:7] цел i, m, d Day [1]:=79; Day [2]:=25; Day [3]:=67; Day [4]:=80; Day [5]:=63; Day [6]:=17; Day [7]:=68; d:= 1; m:= Day [1] нц для i от 2 до 7 если Day[i] > m то m:= Day[i]; d:=i все кц вывод d кон

помогите пожалуйста с информатикой вот такие задачки:

Линейные программы.
Напишите программу на ШАЯ. Вычислите площадь боковой поверхности куба. S=4a(в квадрате)
Условный оператор (ветвление)
Нарисуйте блох-схему. Найдите решение уравнения ax+b=0 если оно отсутствует.
Циклы
Напишите программу на Паскале. Вводится последовательность из N целых чисел. Сколько отрицательных чисел и сумма положительных чисел?
Одномерные массивы
Напишите программу на паскале. В одномерном массиве вычислите сумму положительных элементов.
Двумерные массивы
Напишите программу на паскале. Дан квадратный целочисленный массив. Уменьшить в два раза все его элементы.

Если что извините, надеюсь не много прошу.

пожалуйста сделайте номера 6 7 8

Читайте также

Здравствуйте, мне нужна помощь с программой Excel.

Есть программа, которая преобразует слово из трех букв в число в 32-ичной сс(русс. алф).
После этого, переводит число в 10-ую сс.
Максимум может получиться 6 цифр, минимум 3.
Мне
нужно как-то сделать так, чтобы если у меня три цифры, то добавлялось
спереди три нуля, четыре цифры-добавлялось два нуля, пять
цифр-добавлялся один ноль, шесть-не добавлялось ни одного нуля.



Вы находитесь на странице вопроса "мне нужна помощь ещё с одной задачей.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.