Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Составить программы в Turbo Pascal. 1)Дано три точки A,B,C на числовой оси.Найти длинну отрезка AC и BC и их сумму. 2)Задано четыре целых числа

5-9 класс

a,b,c,d.Выяснить произведение этих чисел больше 300? 3)Дано целое число ,если оно положительное,то прибавить к нему 1,а если отрицательное.то отнять от него 2.Вывести полученое число.

Dasha22011979 27 авг. 2013 г., 5:37:31 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Анастасия02022001
27 авг. 2013 г., 7:35:20 (10 лет назад)

первое

program proga;

uses crt;

var

a,b,c,x,y,z:integer;

begin

clrscr; 

writeln('Введите значения точек');

 readln(a);  readln(b); readln(c); 

x=b-c;

y=c-b;

z=x+y;

readln;

end.

второе

program proga;

uses crt;

var

a,b,c,x,y,z:integer;

begin

clrscr; 

 writeln('Введите 4 числа');

 readln(a);  readln(b); readln(c);   readln(x); readln(y);  

z=a*b*c*y*x;

if z>300 then

writeln('произведение этих чисел больше 300')

else

 writeln('произведение этих чисел меньше 300') ;

readln;

end.

и соответственно третье

program proga;

uses crt;

var

a:integer;

begin

clrscr; 

 writeln('Введите число');

 readln(a);

if a>0 then

a=a+1;

writeln(a) 

else

if a<0 then

a=a-2;

writeln(a) 

 else

writeln('вы ввели 0');

readln;

end.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Ответить

Читайте также

задача pascal

Даны три точки А, В, С на числовой оси. Найти длины отрезков АС и ВС и их сумму.(нужно чтобы прошел тест на taskbook)

Помогите составить программу по информатике в Pascal ABC. Задание 1. С клавиатуры одной строковой вводят имя и фамилию. Составьте программу, которая:

а) определяет, есть ли в определенной строке заданный символ; б) копирует в новую строку имя и выводит его; в) выводит сначала фамилию, а затем имя. Задание 2. Составьте программу, которая в строке "Касіу Ясь канюшыну" заменяет имя "Ясь" на "Янка". Задание 3. Составьте программу, которая в строке "реки горы и болота": а) удаляет слово "горы"; б) Заменяет слово "болота" на "озера". Буду безмерно благодарна!!!

Помогите составить программу по информатике в Pascal ABC. Задание 1. С клавиатуры одной строковой вводят имя и фамилию. Составьте программу, которая: а)

определяет, есть ли в определенной строке заданный символ; б) копирует в новую строку имя и выводит его; в) выводит сначала фамилию, а затем имя. Задание 2. Составьте программу, которая в строке "Касіу Ясь канюшыну" заменяет имя "Ясь" на...

Очень срочно, и очень нужно составить программы по информатике PASCAL ABC, помогите, пожалуйста от этих программ зависит моя четвертная.

1. Составьте программу для определения большего из двух чисел х или у
2. Составьте программу для нахождения площади прямоугольника по заданным сторонам а и б



Вы находитесь на странице вопроса "Составить программы в Turbo Pascal. 1)Дано три точки A,B,C на числовой оси.Найти длинну отрезка AC и BC и их сумму. 2)Задано четыре целых числа", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.