Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

создать массив натуральных четных чисел длины N, и вывести сумму элементов. можно блок схему.

10-11 класс

AL2005 30 апр. 2014 г., 8:50:08 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Doker287
30 апр. 2014 г., 10:30:58 (10 лет назад)

const n=20;
var a:array[1..n] of integer;
i,s:integer;
begin
s:=0;
for i:=1 to n do begin
readln(a[i]);
if a[i] mod 2<>0 then begin
writeln('вы ввели нечетное число. введите заного');
readln(a[i]); end;
s:=s+a[i];
end;
writeln(s);
end.

Ответить

Другие вопросы из категории

Написать

программу, которая бы по введенному номеру времени года (1 - зима, 2 - весна, 3
- лето, 4 - осень) выдавала соответствующие этому времени года месяцы,
количество дней в каждом из месяцев.

1. Производится двухканальная (стерео) звукозапись с частотой дискретизации 16 кГц и глубиной кодирования 32 бит. Запись длится 12 минут, ее результаты

записываются в файл, сжатие данных не производится. Определите размер полученного файла в мегабайтах?

Читайте также

1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы

каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива. 4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных. 5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных. 6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами. Вывести на экран исходный и новый массив. 7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы. 8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.

Составить блок-схему и

указать тип алгоритмов:Найти сумму первых десяти натуральных четных чисел.



Вы находитесь на странице вопроса "создать массив натуральных четных чисел длины N, и вывести сумму элементов. можно блок схему.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.