Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите решить 2 задачи по двумерным массивам

5-9 класс

Da9 12 мая 2014 г., 13:50:08 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kirsanovaira199
12 мая 2014 г., 14:49:41 (10 лет назад)

var
a:array [1..7,1..7] of integer;
i,j,k:integer;
begin
writeln('Массив:');
for i:=1 to 7 do
begin
k:=k+1;
for j:=1 to 7 do
begin
a[i,j]:=j+k;
write(a[i,j]:3);
end;
writeln;
end;
end.

var
a:array [1..7,1..7] of integer;
i,j,k:integer;
begin
writeln('Массив:');
k:=0;
for i:=1 to 4 do
begin
for j:=1 to 7 do
if (j<=k)or(j>=(7-k+1))
then begin a[i,j]:=0; a[8-i,j]:=0; end
else begin a[i,j]:=1; a[8-i,j]:=1; end;
k:=k+1;
end;
for i:=1 to 7 do
begin
for j:=1 to 7 do
write(a[i,j]:2);
writeln;
end;
end.




+ 0 -
Anastasia1V
12 мая 2014 г., 15:39:30 (10 лет назад)

нужно обе решить?

+ 0 -
Violau
12 мая 2014 г., 16:23:55 (10 лет назад)

да

+ 0 -
1894
12 мая 2014 г., 18:36:44 (10 лет назад)

помоги еще 2 решить пожалуйста
1 2 2 2 2 2 2
3 1 2 2 2 2 2
3 3 1 2 2 2 2
3 3 3 1 2 2 2
3 3 3 3 1 2 2
3 3 3 3 3 1 2
3 3 3 3 3 3 1

вот 2
0 0 0 0 0 0 1
0 0 0 0 0 2 0
0 0 0 0 3 0 0
0 0 0 4 0 0 0
0 0 5 0 0 0 0
0 6 0 0 0 0 0
7 0 0 0 0 0 0

+ 0 -
Cweta5
12 мая 2014 г., 19:59:05 (10 лет назад)

сделай новым вопросом. сделаю

+ 0 -
Vika1598
12 мая 2014 г., 21:09:25 (10 лет назад)

все написал

Ответить

Читайте также

мне ооочень срочно нужно!!! пожалуйста помогите!!!!!!!!помогите решить 2 задачи по Ивт в Паскале: 1)составить программу вычисления в массиве A(

N) произведения нечетных элементов 2)Составьте программу вычисления в массиве B(N) максимального среди отрицательных элементов и его номера. заранее огромное спасибо! очень нужно!

Помогите пожалуйста решить правильно и подробно 2 задачи по информатике: 1.Исправьте неточности в описании двумерного массива: Var

A= array[1..n,1..m] of integer;

2. Вставьте пропущенные определения:

… … двумерных массивов каждая строка заключается в дополнительную пару круглых скобок:

const a:mas= ((2,3,1,0),
(1,9,1,3),
(3,5,7,0));



Вы находитесь на странице вопроса "Помогите решить 2 задачи по двумерным массивам", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.