Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

помогите составить программу!пожалуйста!!!!ооочень надо

10-11 класс

ракета запускается с земли со скоростью V(км час) в направлении движения земли по орбите вокруг солнца. составить программу,определяющую результат запуска ракета в зависимости от скорости V.
Известно,что при V16,4 ракета покинет солнечную систему.

Yreslav 08 авг. 2013 г., 17:48:44 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Krasnovasonya66
08 авг. 2013 г., 20:07:09 (10 лет назад)

Решение на VB

Sub Rocket()
    Dim x As Single
    x = InputBox("Введите скорость ракеты в км/с")
    Select Case x
    Case Is < 7.91
        MsgBox "Ракета упадет на Землю"
    Case 7.91
        MsgBox "Ракета будет вращаться вокруг Земли по круговой орбите"
    Case Is < 11.2
        MsgBox "Ракета будет вращаться вокруг Земли по эллиптической орбите"
    Case Is < 16.4
        MsgBox "Ракета будет способна перемещаться в пределах Солнечной системы"
    Case Else
        MsgBox "Ракета покинет Солнечную систему"
    End Select
End Sub

+ 0 -
Fomenkoroman
08 авг. 2013 г., 21:13:38 (10 лет назад)

var v:real;
begin
write('Введите скорость в км/c: ');
readln(v);
if v<7.9 then
  writeln('Ракета упадет на Землю');
if v=7.9 then
  writeln('Ракета будет двигаться вокруг Земли по круговой орбите');
if (v>7.9) and (v<11.2) then
  writeln('Ракета будет двигаться вокруг Земли по эллиптической орбите');
if v=11.2 then
  writeln('Ракета будет двигаться вокруг Солнца по круговой орбите');
if (v>11.2) and (v<16.4) then
  writeln('Ракета будет двигаться вокруг Солнца по эллиптической орбите');
if v>16.4 then writeln('Ракета покинет Солнечную систему');
end.

+ 0 -
Kpv12
08 авг. 2013 г., 23:50:26 (10 лет назад)

Потому что 16.4 это в км/с!

+ 0 -
Lalalallallala
09 авг. 2013 г., 0:51:50 (10 лет назад)

в задании написано км.час

+ 0 -
Vovanchikk
09 авг. 2013 г., 3:41:27 (10 лет назад)

Вранье! При 16,4 км/ч ракета взлетит даже с Земли!! Это скорость велосипеда!

+ 0 -
Ernstl
09 авг. 2013 г., 4:42:19 (10 лет назад)

ну может опечатка,а если в секунду

+ 0 -
607650
09 авг. 2013 г., 7:18:11 (10 лет назад)

программу то можно составить?

Ответить

Другие вопросы из категории

Назовите служебные программы Windows
Решать задачу нужно на древнем ТП7 (Турбо паскаль).

Вычислить сумму элементов каждой строки, вводимого С КЛАВИАТУРЫ ДВУМЕРНОГО массива. Обязательно с клавиатуры. Напишите программу пожалуйста.

pascal abc

1. С

Читайте также

Помогите составить программу, пожалуйста, нужно очень срочно! Пятиугольник ABCDE задан координатами своих вершин

(X1,Y1)(X2,Y2)(X3,Y3)(X4,Y4)(X5,Y5) соответственно. Найти площадь этого пятиугольника используя в качестве подпрограммы a) функцию

Помогите пожалуйста!! ) составить программу в "Pascal abc"!!)

Составить программу вычисления значений функции F(x) на отрезке [а; b] с шагом h.
Результат представить в виде таблицы, первый столбец которой — значения
аргумента, второй — соответствующие значения функции: "F(x) = 1/2 ctg x/4+4"

Помогите составить блок-схему алгоритма и программу на алгоритмическом языке программирования БЕЙСИК обработки одномерного массива.Заполнение массива

элементами организовать путем ввода с клавиатуры.В одномерном массиве из N чисел вывести на экран отрицательные элементы и сообщите об их количестве.Пожалуйста,срочно надо.

1. Составить программу для нахождения наибольшего числа из трех чисел.

2. Составить программу для упорядоченное двух элементов по убыванию.

Пожалуйста помогите составить программу.Заполнить массив из 500 элементов случайными числами в интервале [ 0 .. 100 ] . Отсортировать его по

возрастанию двумя способами – методом «пузырька» и методом «быстрой сортировки» .



Вы находитесь на странице вопроса "помогите составить программу!пожалуйста!!!!ооочень надо", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.