Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Сформируйте массив, содержащий 15 элементов, с помощью датчика случайных чисел. Получите новый массив, каждый элемент которого равен среднему

10-11 класс

арифметическому соответствующего элемента исходного массива и введенного с клавиатуры числа A. В полученном массиве найдите максимальный элемент среди элементов с нечетными номерами. Выведите на экран исходные и полученные результаты. пожалуйста напишите полностью всю программу

Телевика 31 авг. 2016 г., 13:23:19 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
89982308846
31 авг. 2016 г., 16:02:28 (7 лет назад)

var
arr : array [1..15] of real;
a, max : real;
i : integer;
begin
read (a);
randomize;
for i := 1 to 15 do
arr[i] := random (20);
for i := 1 to 15 do
write (arr[i], ' ');
writeln; writeln;
for i := 1 to 15 do
write ((arr[i] + a) / 2, ' ');
max := arr[1];
writeln;
for i := 3 to 15 do
if i mod 2 = 1 then
if arr[i] > max then max := arr[i];
writeln ('max =', max);
end.

Ответить

Другие вопросы из категории

Ребята, помогите, очень очень срочно нужно))

Дано двузначное число. Найти разность между первой и второй его цифрой, используя функции Mod и Div.

Дана последовательность чисел : 12323. К ней применен следующий цикл обработки:

1. Все цифры "1" заменить на "33"
2. Все цифры "2" заменить на "1"
3. Все цифры "3" заменить на "2"

Помогите решить.

В заданном натуральном трехзначном числе имеется четная цифра.Pascal

ЕЩЕ ИНФОРМАТИКА 10 КЛАССС !!!! Помогите

Читайте также

1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными

индексами. выведите на экран исходный массив и полученное среднее арифметическое.
2. Задайте массив из 10 элементов с помощью датчика случайных чисел. замените все элементы с четными индексами максимальными. Выведите на экран исходный и измененный массивы

1)напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел.замените в нем все четные значения элементов суммой

индексов элементов главной диагонали.Выведите на экран исходный и измененный массивы (программа на языке Паскаля)
2)Составьте программу формирования и вывода на экран одномерного массива, состоящего из удвоенных минимальных элементов строк двумерного массива, заданного с помощью датчика случайных чисел

сформулируйте массив содержащий 15 элементов, с помощью датчика случайных чисел. получите новый массив, каждый элемент которого равен квадрату

соответствующего элемента исходного массива. в полученном массиве определите насколько максимальный элемент исходного массива отличается от минимального элемента нового массива. выведите на экран исходные и полученные результаты

ПОМОГИТЕ ПОЖАЛУЙСТА В ПАСКАЛЕ

сформулируйте массив содержащий 15 элементов, с помощью датчика случайных чисел. получите новый массив, каждый элемент которого равен квадрату соответствующего элемента исходного массива. в полученном массиве определите насколько максимальный элемент исходного массива отличается от минимального элемента нового массива. выведите на экран исходные и полученные результаты



Вы находитесь на странице вопроса "Сформируйте массив, содержащий 15 элементов, с помощью датчика случайных чисел. Получите новый массив, каждый элемент которого равен среднему", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.