Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

ПОЖАЛУЙСТА, ПОМОГИТЕ! ПАСКАЛЬ!

5-9 класс

1. Задать случайным образом 10 чисел от 22 до 135. Напечатать те из них, которые больше 100.
2. Задать с клавиатуры А и N. Напечатать значение А в степени N.
3. Задать с клавиатуры N. Напечатать значение N! = 1*2*3*4*...*N.
4. Напечатать большие русские буквы в строчку через 2 пробела.
5. Напечатать маленькие русские буквы в 2 строчки: от "я" до "р", от "п" до
"а".
6. Ввести с клавиатуры 5 значений для Х. Вычислить и напечатать для каждого из них значение Y по правилу:
а) б)
3*X, если X<=-9 X/10, если X<=-9
Y = X-8, если -9 3*X, если X>=9 X/10, если X>=9
7.Напечатать маленькие английские буквы в столбик от "z" до "а".

5250 17 янв. 2017 г., 2:57:28 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Marrya28
17 янв. 2017 г., 4:56:39 (7 лет назад)

PascalABC.NET

1)
 const     n = 10;
 var
   a : array [1..n] of integer;
   i : integer;
 begin 
  randomize; 
   for i := 1 to n do 
    begin 
    a[i] := 22 + random(114); 
    if a[i] > 100 then 
     writeln (a[i]); 
    end;
  end.

2)
 var 
  a,n,r,i : integer; 
   begin 
 r := 1; 
 readln (a,n); 
  for i := 1 to n do 
   r := r * a;
  writeln (r);
   end.

3)

 var 
 n,i,r : integer;
    begin 
 r := 1; 
 readln (n);
   for i := 1 to n do
    r := r *i; 
 writeln (r);
  end.

Ответить

Другие вопросы из категории

2. Сообщение передается шифром. В нём присутствуют только буквы из приведённого фрагмента кодовой таблицы.

Р
Е
Д
И
С
! ! ?
! !
! ?
? ? ?
? !
Определите, какое сообщение закодировано в строчке ? ! ! ! ! ?.

3. Некоторый алгоритм из одной цепочки символов получает новую цепочку следующим образом. Сначала вычисляется длина исходной цепочки символов; если она нечётна, то дублируется средний символ цепочки символов, а если чётна, то в середину цепочки добавляется буква А. В полученной цепочке символов каждая буква заменяется буквой, следующей за ней в русском алфавите (А – на Б, Б – на В и т. д., а Я – на А). Получившаяся таким образом цепочка является результатом работы описанного алгоритма. Например, если исходной была цепочка КОТ, то результатом работы алгоритма будет цепочка ЛППУ, а если исходной была цепочка ВАНЯ, то результатом работы алгоритма будет цепочка ГББОА.
Дана цепочка символов САН. Какая цепочка символов получится, если к данной цепочке применить описанный алгоритм дважды (т. е. применить алгоритм к данной цепочке, а затем к результату вновь применить алгоритм)?
Русский алфавит: АБВГДЕЁЖЗИЙКЛМНОПРСТУФХЦЧШЩЪЫЬЭЮЯ

4. Статья, набранная на компьютере, содержит 4 страницы, на каждой странице 32 строки, в каждой строке 60 символов (включая символы перевода строки или страницы). В одном из представлений Unicode каждый символ кодируется 16 битами. Определите информационный объем статьи в этом варианте представления Unicode.

Небольшой размер файла – один из достоинств …

1) векторной графики
2) растровой графики
3) векторной и растровой графики
4) нет правильного ответа

Читайте также

Пожалуйста помогите создать какую нибудь полезную программу на паскаль , срочно нужно до понедельника, чтобы в этой программе были все темы за 8 класс,

read.writeln.else.to.if и тд которые сможете
Вот пример идеи для программы, в академию поступают какое то количество учеников, нужно написать сколько учеников сдали документы, сколько пришли на экзамен, и сколько учеников кто прошло и не прошло
возможно не возможно создать программу на этой идее, тогда прделагайте свои со своими программами , пожалуйста помогите!

Пожалуйста, помогите!!!!!!!!!! Известно, что в 12-летнем цикле года носят вои названия: мышь, корова, тигр, заяц, улитка, змея, лошадь, овца,

обезьяна, курица, собака и свинья. Зная, что 1984 год был годом мыши, написать программу, выводящую номер года и его название.

Учитель сказал, что это решается через кейс..Только как.ПОЖАЛУЙСТА, ПОМОГИТЕ!!!!!!!!!!

Пожалуйста помогите по информатике

1) исключи лишнее:
а)микрофон, б)колонки, в) наушники , г) монитор
2)исключи лишнее:
а)процессор, б) монитор, в)клавиатура, мышь
3)установите соответствие. Устройство ПК:
1. клавиатура
2. модем
3.центральный процессор
назначение устройств:
а)передача цифровой информации через каналы связи
б)хранение информации
в)обеспечение общего управления ПК, осуществление вычислений по программе, хранящейся в оперативной памяти
г)визуальное отображение информации, находящейся в оперативной памяти
д)ввод алфавитно-цифровых символов
6.Раздели на группы и дай название каждой группе:
а)принтер,б)сканер,г)мышь,д)проектор,е)веб камера,ж)процессор,з)колонки,и)микрофон, к) монитор
Пожалуйста помогите очень срочно.

ПОЖАЛУЙСТА, ПОМОГИТЕ, ПАСКАЛЬ, СРОЧНО!

1. Задать случайным образом 13 элементов числового массива – числа от 10 до 50. Удалить из него:
а) 10-ый элемент;
б) минимальный элемент.

2. Из символьного массива, 7 элементов которого заданы с клавиатуры, удалить максимальный элемент.

Пожалуйста помогите написать 3 несложных задания...

1...Записать на языке паскаля: Условие 1) -3<x<=(меньше или равно)10;
2)x (не равно 0) ,у(не равно 0);
3)x(принадлежит) [-10;0);
4)величина x не кратна 3:

2.Cоставить программу,которая находит меньшее из трёх введённых чисел a,b,c и выводит на экран.

3.Введите три числа a,b,c.Найдите сумму двух наибольших из них.

ПОМОГИТЕ ПОЖАЛУЙСТА,ОЧЕНЬ ВАЖНОЕ ЗАДАНИЕ,ОТВЕЧУ ВЗАИМНОСТЬ...)
Огромное спасибо за ранее...



Вы находитесь на странице вопроса "ПОЖАЛУЙСТА, ПОМОГИТЕ! ПАСКАЛЬ!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.