Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Решить программу с помощью циклов while и repeat.

5-9 класс

Посчитать сумму чисел больше 20 , но меньше 100, кратное 3.

Vysotskaya1981 05 апр. 2014 г., 17:30:48 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Medznitovna
05 апр. 2014 г., 19:16:59 (10 лет назад)

var summ, i: integer;
begin
summ:=0;
for i:=21 to 99 do if (i mod 3)=0 then summ:=summ+i;
write ('сумма чисел кратных трём= ',summ);
end.

var summ, i: integer;
begin
i:=21;
sum:=0;
while (i<100) do begin
 if (i mod 3)=0 then summ:=summ+i;
 i:=i+1;
 end;
write ('сумма чисел кратных трём= ',summ);
end.

var summ, i: integer;
begin
i:=21;
summ:=0;
repeat
 if (i mod 3)=0 then summ:=summ+i;
 i:=i+1;
 until (i>=100);
write ('сумма чисел кратных трём= ',summ);
end.



Ответить

Другие вопросы из категории

решите пожалуйста 10+sqr(2+1)
№1)Укажите натуральные модэли

ВАРИАНТЫ
Физическая карта
Глобус
График зависимости расстояния от времени
Макет здания
Схема узора для вязания крючком
Муляж яблоко
Манекен
Схема метро
№2)Укажите образные информационные модели
ВАРИАНТЫ
Рисунок
Фотография
Словесное описание
Формула
№3)Отметьте пропушеное слово.
Словесное описание горного ландшафта является....... моделью
ВАРИАНТЫ
Образной
Знаковой
Смешаной
Натуральной
№4)Укажите пары объектов о котрых можно сказать что они находятся в отношении (объект-модель)
ВАРИАНТЫ
Компьютер-процес
Новосибирск-город
Слякоть-насморк
Автомобиль-техническое описание автомобиля
Город-путеводитель по городу

помогите, программа не работает, нужно разложить 4-хзначное число на цифры

var a,a1,a2,a3,a4:integer;
begin
write ('vv ch');
read (a);
a1:= a/1000;
a2:= a/100 mod 10;
a3:= a/10 mod 10;
a4:= a mod 10;
write (a1,a2,a3,a4);
end.
где ошибка!!!!????

Читайте также

ПОМОГИТЕ НАПИСАТЬ ХОТЯ БЫ ОДНУ ЗАДАЧУ НА Pascal ОНИ НЕ СЛОЖНЫЕ , А Я ДАЮ МНОГО ПУНКТОВ!! За 2 лучший ответ! Без плагиата! 1.Написать

программу,используя оператор цикла While,которая будет вводить целые положительные числа не превышающие 100. Найти сумму квадратов чисел 2.Написать программу используя оператор цикла Repeat,которая будет вводить целые числа до тех пор пока не будет введён 0.Подсчитать среднее арифметическое введённых чисел.



Вы находитесь на странице вопроса "Решить программу с помощью циклов while и repeat.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.