Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Задан двумерный массив A [5, 10]. Получить новую матрицу путем деления всех элементов исходной матрицы на её наибольший по модулю элемент.

5-9 класс

2325alina 15 янв. 2015 г., 16:20:30 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Krasotka242003
15 янв. 2015 г., 17:20:46 (9 лет назад)

var a:array[1..5,1..10] of integer;
b:array[1..5,1..10] of real;
i,max:integer;
begin max:=0;
for i:=1 to 5 do 
for j:=1 to 10 do begin
read(a[i,j]);
if abs(a[i])> max then max:=a[i];
end;
for i:=1 to 5 do 
for j:=1 to 10 do begin
b[i,j]:=a[i,j]/max
write(a[i,j]);
end;
end.



Ответить

Другие вопросы из категории

Помогите с первым номером !
Выполнить задания, связанные с Turbo Pascal: 1) Какой оператор позволяет менять значения переменных и вычислять

значения выражений?

2) Выполнить алгоритм при x=345:

Начало

ввод x

a=x div 100

b=x div 10 mod 10

c=(a+b)/2

вывод a

вывод b

вывод c

конец

3) Что появится на экране после выполнения фрагмента программы:

a:=7;

b:=5;

a:=a-b;

Writeln(b-a*2);

Writeln('a=',a,'b=',b);

4) Дана сторона квадрата, найти его периметр.

5) Дано трёхзначное число. В нём зачеркнули последнюю справа цифру и приписали её в начале. Найти полученное число.

*Задачи 4 и 5 решить на языке программирования, используя математические функции.

срочно помогите !!!!!!!!!!!!!!!!!!

Читайте также

Последняя задача...если вы мне поможете,то в аттестате 4 будет....пожалуйста помогите.вот:Сформируйте массив содержащий 15 элементов,с помощью датчика

случайных чисел.Получите новый массив,каждый элемент которого равен удвоенному соответствующему элементу исходного массива.В полученном массиве найдите максимальный элемент среди элементов,номера которых кратны трем.Выведите на экран исходные и полученные результаты

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.

2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0;20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.

Решить задачи на языке программирования в Turbo Pascal: 1) Дан массив, состоящий из 10 чисел, значения могут быть

от -100 до 100. Определить минимальное положительное число.

2) Дан массив, состоящий из 10 чисел. Найдите номера тех элементовв масива, которые наименее различаются.

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!!! 1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.

Найти сумму элементов данного массива.
2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.
Найти значение максимального элемента массива.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.



Вы находитесь на странице вопроса "Задан двумерный массив A [5, 10]. Получить новую матрицу путем деления всех элементов исходной матрицы на её наибольший по модулю элемент.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.