Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дано трёхзначное число. Определить,кратна ли трём сумма кубов его цифр.

10-11 класс

MASHA190602 28 марта 2015 г., 12:29:19 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
7Дианка7
28 марта 2015 г., 15:24:10 (9 лет назад)

var n, s: integer;
begin
  readln(n);
  n := abs(n);
  while n <> 0 do begin
    s := s + Trunc(Power(n mod 10, 3));
    n := n div 10;
  end;
  writeln(s mod 3 = 0);
end.

Ответить

Другие вопросы из категории

Написать программу в паскале, которая после введенного с клавиатуры числа(в диапазоне от 1 до 99), обозначающий денежную единицу, дописывал слово

"Копейка". Например ,5 копеек,41 копейка и тд.

Вот мои попытки создать программу:

Program Kopeika;
Var a:integer;
begin
Writeln('Vvedite chislo');
Readln(a);
Case a of
'1,21,31,41,51,61,71,81,91': a:='Kopeika ';
'2..4,22..24,32..34,42..44,52..54,62..64,72..74,82..84,92..94': a:='Kopeiki ';
'5..20,25..30,35..40,45..50,55..60,65..70,75..80,85..90,95..99': a:=' Kopeek';
end;
Readln;
end.

Помогите! Что здесь не так? как достроить крышу??

и помогите, пожалуйста, окно сделать

Помогите)

Дана последовательность действительных чисел поменять местами наибольший и наименьший элементы

Поясните пожалуйста, откуда в условии видно, что 2 знака кодируются 10 битами? A 9 № 3684.

Для пе­ре­да­чи чисел по ка­на­лу с по­ме­ха­ми ис­поль­зу­ет­ся код
про­вер­ки чет­но­сти. Каж­дая его цифра за­пи­сы­ва­ет­ся в дво­ич­ном
пред­став­ле­нии, с до­бав­ле­ни­ем ве­ду­щих нулей до длины 4, и к
по­лу­чив­шей­ся по­сле­до­ва­тель­но­сти до­пи­сы­ва­ет­ся сумма её
эле­мен­тов по мо­ду­лю 2 (на­при­мер, если пе­ре­даём 23, то по­лу­чим
по­сле­до­ва­тель­ность 0010100110). Опре­де­ли­те, какое число
пе­ре­да­ва­лось по ка­на­лу в виде 01100010100100100110? 1) 6543

Читайте также

1.Дано двузначное число.Определить: a.какая из его цифр больше,первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число.

Определить,равен ли квадрат этого числа учетверённой сумме кубов его цифр. Например, для числа 48 ответ положительный, для числа 52-отрицательный. 3. Дано двузначное число. Определить: a. кратна ли трём сумма его цифр b. кратна ли сумма его цифр числу a. 4. Дано трёхзначное число Определить,равен ли квадрат этого числа сумме кубов его цифр. 5. Дано двузначное число,определить:входит ли в него цифра 3: входит ли в него цифра a.

Дано натуральное число: определить а) количество цифр в нем б)сумму его цифр в)произведение его цифр г)среднее арифметическое его цифр

д)сумму квадратов его цифр е)сумму кубов его цифр ж)его первую цифру з)сумму его первой и последней цифр

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

4 задачи: ввести натуральное число и определить, верно ли, что сумма цифр равна 10 (через repeat и until)//// ввести натуральное

число и определить, какие цифры встречаются несколько раз (через repeat и until)///

ввести целое число и найти сумму его цифр (через while)

ввести целое число и определить , верно ли, что в его записи есть две одинаковые цифры(через while)

всё через паскаль абс



Вы находитесь на странице вопроса "Дано трёхзначное число. Определить,кратна ли трём сумма кубов его цифр.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.