Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Паскаль.Заполнить одномерный массив случайными числами от -70 до 30,посчитать сумму отрицательных элементов массива и вычислить её абсолютную

5-9 класс

величину.

Ravlyuk97 06 февр. 2017 г., 18:39:27 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Gagik
06 февр. 2017 г., 21:05:17 (7 лет назад)

var
a:array[1..1000] of integer;
n, i, suma:integer;
begin
write('введите количество чисел массива ');
readln(n);
suma:=0;
for i:=1 to n do
begin
a[i]:=random(101)-70;
if(a[i]<0) then
suma:=suma+a[i];
end;
write('массив ');
for i:=1 to (n-1) do
write(a[i],', ');
writeln(a[n],' ');
writeln('сумма отрицательных элементов ',abs(suma));
end.

Ответить

Другие вопросы из категории

Приведите примеры объекта плиззз
Расписание звонков. В школе задается начало учебного дня (8—30), продолжительность урока (45 мин), продолжи¬тельность обычного (5 мин) и большого

(15 мин после третьего урока) перерьшов, количество уроков (6). Получить расписание звонков на учебный день.

Помогите пожалуйста!!!

Читайте также

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!!! 1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.

Найти сумму элементов данного массива.
2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.
Найти значение максимального элемента массива.

в массиве действительных чисел с от 1 до 11 посчитать сумму отрицательных элементов, произведение положительных и вывести на экран номера нулевых элемен

тов.
ПОМОГИТЕ ПОЖАЛУЙСТА!!!с помощью паскаля, а числа задавать можно любым способом.

1)составьте программу,которая заполняет массив a[1..10] случаынми целыми числами в диапазоне от 0 до 10 и находит минимальный элемент массива среди

элементов с нечётными индексами

2)составьте программу,которая заполняет массив a[1..10]случайными целыми числами в диапазоне от 0 до 10,находит максимальный элемент массива,а затем вычисляет,сколько раз он встречается в массиве

1.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество.

2.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50. Заменить все четные элементы на их квадраты, а нечетные удвоить.



Вы находитесь на странице вопроса "Паскаль.Заполнить одномерный массив случайными числами от -70 до 30,посчитать сумму отрицательных элементов массива и вычислить её абсолютную", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.