Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

1. Исправить все ошибки в данном фрагменте программы:

10-11 класс

If a>=10 and a<=99 Then
Writeln (a ‘ двузначное число ’);
Writeln (‘ его квадрат = ’, Sqrt(a));
Else (a,

Kotashok1234567890 24 мая 2014 г., 5:41:08 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
АрТёМ669
24 мая 2014 г., 7:13:25 (9 лет назад)

If (a>=10) and (a<=99) Then Begin
Writeln (a ‘ двузначное число ’);
Writeln (‘ его квадрат = ’, Sqr(a));
end
Else (a, 

Ответить

Другие вопросы из категории

помогите ответить на вопросы))))1Что такое тег?

2Какие теги обуславливают начало HTML-программы?

3Какой тег обуславливает название Веб-страницы?

Читайте также

дан фрагмент программы

Y=0
FOR K:=15 DOWNTO 1 DO;
begin
Y=Y*K;
end;
напишите запись фрагмента программы, реализирующего алгоритм циклической структуры..
напишите пожалуйста полный ответ...))

Помогите с тестами по информатике!!! А1. Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 3 + 3*4;

b := (a div 10) + 4;

a := (b mod 10) + 2;

b:= a + b;

a:= a mod 2 + b div 3;

1) a=4, b=14;

2) a= 24, b= 6;

3) a=5, b=12;

4) a=8, b=12.

А2. Для какого из указанных значений числа X истинно высказывание

((X < 5)→(X < 3)) Ù ((X < 2)→(X < 1))

1) 1

2) 2

3) 3

4) 4

А3. Укажите, какое логическое выражение равносильно выражению ¬(A Ú ¬B Ú C) ?

1) ¬A Ú B Ú ¬C

2) A Ù ¬B Ù C

3) ¬A Ú ¬B Ú ¬C

4) ¬A Ù B Ù ¬C

X

Y

Z

F

1

1

1

1

1

1

0

1

1

0

1

1

А4. Символом F обозначено одно из указанных ниже логических выражений от трех аргументов: X, Y, Z. Дан фрагмент таблицы истинности выражения F (см. таблицу справа).

Какое выражение соответствует F?

1) X Ú ¬Y Ú Z

2) X Ù Y Ù Z

3) X Ù Y Ù ¬Z

4) ¬X Ú Y Ú ¬Z

А5. Что будет выведено на печать в результате выполнения следующих операторов:

a := 5; b := 10;

write( 'сумма двух чисел ' ); write( 'a+b' );

write( ' = ', a+b );

1) сумма двух чисел 5+10 = 15

2) сумма двух чисел a+b = 15

3) сумма двух чисел 5+10 = a+b

4) сумма двух чисел a+b = 5+10

5) ни один из ответов 1-4 не верен

А6. Чему было равно значение переменной a, если после выполнения операций

b := sqrt( sqr(a+1) );

c := -b;

a := 1 + 2 / (c-b);

она стала равна 0 ?

1) 2

2) 0

3) –1

4) любое вещ. число, не равное -1

5) ни один из ответов 1-4 не верен

А7. Чему будет равно значение А после выполнения цикла

а:=1024;

While a>0 do

a:=a / 2;

1) 0

2) 1

3) зациклится

4) 512

5) ни один из ответов 1-4 не верен

A8. Сколько раз выполнится тело цикла?

A:=32;

While A>2 do

Begin A:=A / 2; writeln(‘A’); end;

1) 8

2) 6

3) 5

4) 4

5) 3

1)Дан фрагмент электронной таблицы в режиме отображения формул.(фото с цифрой 1)

Какой вид примет таблица после выполнения команды:КОПИРОВАТЬ B1 в B2:B3.
2)Дан фрагмент электронной таблицы в режиме отображения формул.(фото с цифрой 2)
Чему будут равны значения клеток B2 и B3 в режиме отображения после выполнения команды: КОПИРОВАТЬ B1 в B2:B3.

1)Определите значение переменной c после выполнения следующего фрагмента программы:

a :=40 ;
b := 10;
a := - a / 2*b,;
if a > b then
c := b - a
else c := a - 2 * b

2)Определите значение переменной c после выполнения следующего фрагмента программы:
a := 5;
a := a + 6;
b := - a;
c := a - 2 * b

В программе используется одномерный целочисленный массив А с индексами от 0 до 10. Ниже представлен фрагмент программы в котором значения элементов

сначала задаются,а затем меняются.

Нц для i от 0 до 10

А [ i ] := i

кц

Нц для i от 0 до 4

С := A[ i ]

A[ i ] := A [10 - i ]

A [10 - i ] :=C

кц

Чему будут равны элементы массива после выполнения фрагмента программы?

1) 10 9 8 7 6 5 4 3 2 1 0

2) 0 1 2 3 4 5 6 7 8 9 10

3) 10 9 8 7 6 5 6 7 8 9 10

4) 0 1 2 3 4 5 4 3 2 1 0



Вы находитесь на странице вопроса "1. Исправить все ошибки в данном фрагменте программы:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.