Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

PASCAL

5-9 класс

Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, оканчивающихся на 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 5.Количество чисел не превышает 100. Введённые числа по модулю
не превышают 300.

ForestJk 27 мая 2014 г., 16:21:24 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nastya156karkach
27 мая 2014 г., 18:07:19 (9 лет назад)

uses crt;
var sum,k,i:integer;
begin
     readln(k);
     writeln;
     sum:=0;
     repeat
           read(i);
           if (i>0) and (i mod 10=5) then sum:=sum+i;
           k:=k-1;
     until k=0;
     writeln(sum);
end.

----
Так как последовательность натуральных чисел, я ввела условие i>0 для суммы. Если подразумевается, что вводятся только положительные числа, это условие можно убрать.

Ответить

Другие вопросы из категории

таблица помогите срочно))

бит байт КБ
2576
208
1,5
2(13вверху)
2(11вверху)
2(2²)

Сравните ...

1) 1536 бит (</=/>) 0,25 Кбайт
2) 1536 бит (</=/>) 1,5 Кбайт
(1 байт= 8 бит)

Определите значение переменной f после выполнения фрагмента алгоритма

f:=1
начало цикла для i от 1до 5
f:-fxi
конец цикла

Читайте также

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу,которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.


1.Какое значение переменной S будет напечатано после выполнения фрагмента программы,записанной на языке программирования TURBO PASCAL:A:=2В: = 3;

if A>B then S: = A+B;
writeln (S);
Варианты ответов:1)5 ;2)6; 3)7; 4)8

2. Какое значение переменной S будет напечатано после выполнения фрагмента программы, записанной на языке программирования PASCAL:
S: =1;
N: =1;
while N<=3 do
begin
S: = S*N;
N: = N+1;
end;
writeln(S);
Варианты ответов: 1)2 ; 2)1; 3)0; 4)4

1) дано четырёхзначное число. вывести максимальную и минимальную цифру. pascal abc

2) дано четырёхзначное число. Что больше: произведение цифр числа или их утроенная сумма. pascal ABC



Вы находитесь на странице вопроса "PASCAL", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.