Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

помогите написать на с++

10-11 класс

Tdhju 16 окт. 2016 г., 8:55:50 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ira20030124
16 окт. 2016 г., 10:25:29 (7 лет назад)

#include <stdio.h> //ввод и вывод данных
#include <conio.h> //чтобы getch () работал
#include <math.h> //в прогр. есть математические ф-ии


int main ()
{
  float x, f;
  do{ //пока не введем х больше 0
    printf ("Введите x:");
    scanf ("%f", &x);
  }while (x <= 0); //из - за логарифма х должен быть больше 0
  f = log10(x) - acos(2 / x); //считаем
  printf ("Результат: %f", f); //выводим на экран
  getch (); //задержка экрана
  return 0;
}

+ 0 -
Jsi0036
16 окт. 2016 г., 13:11:27 (7 лет назад)

Именно на C++:

 

#include <iostream>
using std::cout;
using std::cin;
using std::endl;
#include <cmath>
using std::acos;
using std::log10;

int main()
{
   double f, x;

   cout << "Enter x: ";
   cin >> x;

   cout << "f(x) = " << (f = log10(x) - acos(2 / x)) << endl;

   cin.get();
   return 0;
}

Ответить

Другие вопросы из категории

помогите решить срочно
Какое количество информации получит второй игрок в игре «Угадай

число» при оптимальной стратегии, если первый игрок загадал число:
от 1 до 64?

Читайте также

программа на C++ в визуальном режиме (есть несколько вариантов кода программы)

доброй ночи, уважаемые программисты и успевающие в учебе студенты. помогите, пожалуйста, написать программу на C++ (в визуальной вкладке).

ВОТ ЗАДАНИЕ:
дано три переменные вещественного типа. если их значения упорядочены по возрастанию или убыванию, то удвоить их; иначе заменить значение каждой переменной на противоположное. вывести значения переменных.


я прикрепила несколько тестовых файлов (блокнот) в которых есть несколько вариантов решение этого задание (то есть коды программ), а вы скажите какой из них лучше всего подходит, а также скажите какие компоненты нужно кинуть на форму-дизайн (то есть какие кнопки, и что на них писать). в этих 3 файлов есть написанный код программы, нужно написать: на какие кнопки что писать и какой вариант решение больше подходит.

заранее огромное спасибо всем за помощь!!!

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

Помогите написать программу по Информатике! Найти произведение двузначных нечетных чисел, кратных

13.

Нужно написать программу на цикле с предусловием, на Паскале.



Вы находитесь на странице вопроса "помогите написать на с++", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.