Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Найти сумму цифр любого числа с помощью String

5-9 класс

Libasan 04 сент. 2016 г., 18:03:47 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Endonova82
04 сент. 2016 г., 19:50:27 (7 лет назад)

Program Pr1;
uses crt;
var stroka,tmp:string;
i,a,b,c:integer;
Begin
clrscr;
writeln('Введите числа для сложения в форме a+b');
readln(stroka);
i:=1;
while stroka[i] in ['0'..'9'] do i:=i+1;
tmp:=copy(stroka,1,i-1);
delete(stroka,1,i);
val(tmp,a,c);
val(stroka,b,c);
c:=0;
c:=a+b;
writeln(c);
end.

 

Ответить

Другие вопросы из категории

Помогите. Напишите ответ: а).......б).........

а) Совокупность всех компьютерных программ.
б) Пакет программ, управляющий работой компьютера и обеспечивающий взаимодействие между человеком и компьютером.

НАЙДИТЕ ЛИШНЕЕ И ЗАЧЕРКНИТЕ:

ТЕКСТОВАЯ ГРАФИЧЕСКАЯ ЗРИТЕЛЬНАЯ ЧИСЛОВАЯ
помогите пожалуйста!!!!!!!))))))))

Читайте также

Нужно написать программу на языке Паскаля!

Вот задача:
Найти сумму цифр данного числа



Вы находитесь на странице вопроса "Найти сумму цифр любого числа с помощью String", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.