Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

создать массив целых чисел, найти сумму четных элементов массива, результат вывести на экран

10-11 класс

Aez1974 26 нояб. 2013 г., 10:44:54 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Rashidcheb911
26 нояб. 2013 г., 12:33:35 (10 лет назад)

Const     n=5;
var         A:array [1..n] of integer;
             i:byte;
             S:integer;
begin
writeln ('vvedi mas A');
for i:=1 to n do
readln (A[i]);
S:=0;
for i:=1 to n do
if i mod 2=0 then
S:=S+A[i];
writeln ('S=',S);
readln;
readln
end.



+ 0 -
Krasotka7
26 нояб. 2013 г., 14:20:19 (10 лет назад)

На Perl:
#!/usr/bin/perl
for($i=0; $i<100; $i++){
  @arr[i]=int(rand(100));
  if (@arr[i]%2==0){$sum+=@arr[i]}
};
print $sum;

Ответить

Другие вопросы из категории

Помогите пожалуйста

Если в слове А его вторую половину, буквы которой образуют слово В, заменить на слово С, то получится слово Д. Слова А и Д- носители информации в компьютерах первых поколений; В- чертёж поверхности Земли; С- элемент матричного принтера.
В ответе запишите через один пробел сначала слово, которое зашифровано буквой А , затем слово, зашифрованное буквой С. Например дискета диск.

Содержимое текстового файла

Ivanov
Pugachov
Sidirov Vasya
Hello world!!!
Что будет на экране если выполнить данный фрагмент программы

Читайте также

1.Дан целочисленный массив X(N). Найти сумму четных элементов массива .Если эта сумма больше заданного числа Z , то у элементов , расположенных на

нечетных местах , сменить знак на противоположный ,иначе выдать соответствующее сообщение.

2.Дан массив X(N,M) . Среди четных столбцов массива найти сумму положительных элементов

3.Найти произведение элементов каждого столбца массива принадлежащих промежутку [2,6] . Из полученных значений сформировать одномерный массив.

Дан массив X(N).Найти среднее арифметическое элементов массива,значения которых заключены в интервале [-3;3]. Если эта величина больше

заданного числа Z,то найти сумму четных элементов,иначе- произведение нечетных элементов.

Друзья,очень нужна ваша помощь,пожалуйста,если Вы решили мне помочь-отпишитесь. Заранее спасибо!

Help!!! Дан массив целых чисел, состоящий из 10 элементов.Заполнить его с клавиатуры. Найти:

-Удвоенную сумму положительных элементов;

-Удалить все четные элементы массива.

1. Задайте массив из 10 элементов с помощью датчика целых случайных чисел. Найдите сумму четных элементов массива. Выведите на экран исходный массив и

полученную сумму.
2. Дан массив В(n). Определите произведение элементов, кратных 3. Выведите на экран исходный массив и найденное произведение.

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .



Вы находитесь на странице вопроса "создать массив целых чисел, найти сумму четных элементов массива, результат вывести на экран", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.