Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дано трехзначное натуральное число А. Получить новое натуральное число В, который являлся бы перевёртышём числа А (например, А=123, тогда В=321). Помогите

1-4 класс

с решением пожалуйста.

ZedRot1 26 марта 2014 г., 22:18:37 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
LiliyaI
26 марта 2014 г., 23:04:54 (10 лет назад)

var a: string;
    i, b: integer;
begin
     readln(b);
     a := inttostr(b);
     b := 0;
     for i := length(a) downto 1 do
         b := b * 10 + strtoint(a[i]);
     writeln(b);
end.

Я люблю строки =)

Ответить

Другие вопросы из категории

Максим в 2 раза старше своей сестры Тани. У Тани было в 3 раза больше орехов, чем у Максима. Число орехов у Тани больше числа лет Максима на 35, а

число орехов у Максима больше числа лет Тани в 3 раза. Сколько лет каждому? Сколько у каждого орехов?

=Лучше с решением=

их множество на клавиатуре
Вставь пропущенные слова 1) Файл - это информационный ______. 2) Как и любой объект,__________ Имеет имя и свойства. 3)Имя и свойства являются

характеристикой_________.(Слова которые надо вставить: Папка размещёния, имя файла, размер файла, дата создания, объект, файл.)

Читайте также

Задумайте любое трёхзначное число, не превышающее 300. Запишите шестизначное число, в записи которого дважды повторено исходное число. Полученное

шестизначное число разделите на 13, результат разделите на 11 и на 7. У вас должно получиться исходное число. Почему получается такой результат?

Задумай трёхзначное число любое. 1) Умножить задуманное число на 3 2) прибавить 9 3) прибавить 15 4) вычесть 3 5)

разделить на 3

6) вычесть из ответа задуманное число

Должно получится 7 .Можно задумать другое число получится тоже 7

Придумайте свою цепочку преооброзаваний числа, такую, чтобы в результате получалось число 5

Напишите программу, которая вводит два вещественных числа, a и b ( a < b ), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a ,

b ) .

Входные данные
Входная строка содержит два вещественных числа a и b , разделённых пробелом. Гарантируется, что a < b .

Выходные данные
Нужно вывести в одной строке через пробел 5 случайных вещественных чисел в полуинтервале [ a , b ) с тремя знаками в дробной части.



Вы находитесь на странице вопроса "Дано трехзначное натуральное число А. Получить новое натуральное число В, который являлся бы перевёртышём числа А (например, А=123, тогда В=321). Помогите", категории "информатика". Данный вопрос относится к разделу "1-4" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.