Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Известны размеры двух ящиков(длина, ширина, высота) .Определить объем какого ящика больше . Размеры меньшего ящика увеличить в два раза и снова сравнить

5-9 класс

объемы ящиков . Вывести на экран больший объем. Составить программу в паскале.

Известны радиусы и координаты центров двух окружностей таких , что одна окружность не содержит внутри другой . Определить пересекаются ли эти окружности (расстояние между центрами должно быть меньше суммы радиусов). Определит площадь большей окружности. Составить программу в паскале

Aniperleonid 29 мая 2014 г., 3:05:52 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
SrgejTfuli
29 мая 2014 г., 4:53:22 (9 лет назад)

Даю пример на c#, авось поможет придумать код на паскале, т.к сам онли в c#:
int perva, pervb, pervv;
int vtora, vtorb, vtorv;
Console.WriteLine("Введите длину первого ящика");
perva = Convert.ToInt32(Console.ReadLine());
Console.WriteLine("Введите ширину первого ящика");
pervb = Convert.ToInt32(Console.ReadLine());
Console.WriteLine("Введите высоту первого ящика");
pervv = Convert.ToInt32(Console.ReadLine());
Console.WriteLine("Введите длину второго ящика");
vtora = Convert.ToInt32(Console.ReadLine());
Console.WriteLine("Введите ширину второго ящика");
vtorb = Convert.ToInt32(Console.ReadLine());
Console.WriteLine("Введите высоту второго ящика");
vtorv = Convert.ToInt32(Console.ReadLine());
int result;
int result2;
result = perva * pervb * pervv;
result2 = vtora * vtorb * vtorv;
obratno:
if (result > result2)
{
int anotherresult;
anotherresult = result2 * 2;
goto obratno;
}
if (result < result2)
{
int anotherresult2;
anotherresult2 = result * 2;
goto obratno;
}







Ответить

Читайте также

известна длина,ширина,высота ящика,на складе n ящиков.найти объем ящика и общий объем всех ящиков.

Написать программу и желательно блок схему,заранее спасибо

два фермера имеют земельные учаски треугольной формы. известны длины трёх оград возведённых вокруг каждого земельного участка:a1,b1,c1,a2,b2,c2.составте

программу определяющую равны ли площади этих земельных участков.если участки имеют разные площади то определите у какого фермераучасток больше.PascalABC

1) определите объем памяти, необходимый для хранения unicode следующей фразы: "Как удивительны в России вечера"

2) определите объем памяти, необходимый для хранения растрового 16 цветного изображения 100*100 точек

Дайте пожалуйста условие и решение: 1. текст содержит 2048 символов, один символ кодируется 2 байтами. Каков объём сообщения в битах? 2. объём файла

хранящегося на диске 514 Кбайт, при форматировании диска размер кластера составил 8 Кбайт. Определите кол-во кластеров, которое потребуется для хранения данного файла на диске. 3. сколько цветов будет содержать палитра, если на один пиксель отводится 4 бита памяти? 4.для кодирования одного пикселя служит двоичный код 1000. сколько цветов можно закодировать в этом пикселе? 5. сколько битов памяти достаточно для кодирования одного пикселя 16-ти цветного изображения? 6. известно, что для хранения файла используется 31 кластер, размер кластера составляет 6 Кбайт, при этом последний кластер заполнен на половину. какой объём файла в килобайтах? 7. каков минимальный объём видеопамяти, необходимый для хранения графического изображения, занимающего область экрана 512 x 512 точек, где каждая точка может иметь один из 512 цветов? 8. Средняя скорость передачи данных по каналу связи равна 28800 бит/с. сколько секунд потребуется для передачи по этому каналу цветного изображения размером 640 x 480 пикселей, при условии, что цвет каждого пикселя кодируется 3 байтами. 9. на одной странице размещается 60 строк текста по 25 символов в строке. принтер печатает 6 страниц в минуту. за сколько секунд принтер напечатает 27000 символов? 10. определите к какой группе относятся действия: 1) редактирование 2) форматирование а) замена одного символа на другой; б) вставка пропущенного слова; в) изменение шрифта; г) удаление фрагмента текста; д) выравнивание текста по ширине; е) автоматическая проверка правописания; ж) изменение междустрочного расстояния; з) изменение размеров полей страницы; и) удаление ошибочного символа; к) поиск и замена; л) перемещение фрагмента текста. 11. укажите какие из примеров удовлетворяют маске: ?ese*ie.?t* 1) seseie.ttx 2) esenie.ttx 3) eseie.xt 4) sesenie.txt



Вы находитесь на странице вопроса "Известны размеры двух ящиков(длина, ширина, высота) .Определить объем какого ящика больше . Размеры меньшего ящика увеличить в два раза и снова сравнить", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.