Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Задача D Три числа

10-11 класс

Opolina2344177 21 янв. 2016 г., 15:50:39 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Авдей
21 янв. 2016 г., 17:41:43 (8 лет назад)

uses crt;
var i,j,k,n,sum:integer;
a:array[1..100] of integer;
flag:boolean;
begin
flag:=false;
writeln('Input N');
read(n);
writeln('Input elements');
for i:=1 to n do
read(a[i]);
for i:=1 to n do
for j:=1 to n do
for k:=1 to n do
if (i<>j) and (j<>k) and (i<>k) then
if a[i]+a[j]+a[k]=0 then
begin
writeln('Yes');
flag:=true;
halt;
end;
if flag=false then
writeln('No');
end.

Ответить

Другие вопросы из категории

В маркированном списке для обозначения элемента списка используются:

А) латинские буквы;
Б) римские цифры;
В) графические значки

C=a/b+b/a+1 записать на языке басик.

y=cos2x+sinx/4. Составьте программу для расчетов

помоги пожалуйста Мне

Читайте также

Взять три своих инициала и закодировать( К С Б, где А=12, Б=13, В=14 и т.д) Полученные три числа перевести в двоичную систему счисления, вычислить их

сумму и перевести в десятичную систему счисления. Эти три числа перевести в восьмеричную систему , вычислить их сумму и перевести в десятичную систему счисления. Эти три числа перевести в шестнадцатиричную и вычислить их сумму, и перевести в десятичную

Программирование. Даны три вещественных числа a,b,c. Существует ли треугольник со сторонами a,b,c? program dz1; uses crt; var

a,b,c:integer;

begin

writeln('введите три числа: ');

readln(a,b,c)

а дальше не знаю помогите пожалуйста!!!!)

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Всем привет! Помогите пожалуйста по информатике. Задача: ввести целое число и найти сумму его цифр. Пример: введите целое число:1234. Сумма цифр числа 1

234 равна 10. Задача: сумма цифр ввести целое число и определить верно ли, что в его записи есть 2 одинаковые цифры. Пример: введите целое число 1234 нет введите целое число 1224 да

Ввести с клавиатуры три числа (x,y,z). Если x<y<z, то все числа удвоить.

Если z<y<x, то максимальное число возвести в квадрат. Если числа не
удовлетворяют ни одному из условий – обнулить их.



Вы находитесь на странице вопроса "Задача D Три числа", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.