Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Тема "Массивы и двумерные массивы"

10-11 класс

Задачи:
- N учащихся одного класса получили оценку за контрольную работу. Сколько учащихся получили "двойку"?
- Дан двумерный массив А размером 3*3,заполненный с клавиатуры. Требуется умножить элементы этого массива на 4 ,если А(1,1)>0 или на 7, если А(1,1)<0.
- Дана строка символов,состоящая только из цифр. Опеределить,сколько раз среди них встречается цифра 5?

Lexadalnaboy 06 авг. 2016 г., 20:20:26 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Imarta23
06 авг. 2016 г., 21:21:37 (7 лет назад)

1) Не достаточно информации

2)

Program help1;
Uses Crt;
Var a : Array[1..3, 1..3] of Integer;
i, j, m : Integer;

Begin
ClrScr;

For i := 1 to 3 do
For j := 1 to 3 do
Begin
Write('Введи a[', i, ', ', j, ']: ');
Readln(a[i, j]);
End;

If a[1, 1] > 0 then
m := 4;
If a[1, 1] < 0 then
m := 7;

For i := 1 to 3 do
For j := 1 to 3 do
a[i, j] := a[i, j] * m;
End.

3)

Program help2;
Uses Crt;
Var s : String;
n, i : Byte;

Begin
ClrScr;

Write('Введи строку: ');
Readln(s);

n := 0;

For i := 1 to Length(s) do
if s[i] = '5' then
inc(n);

Write('Цифра 5 встречается ', n, ' раз');
End.

Ответить

Другие вопросы из категории

Помогите с 2 и 3 фото прикрепил
тактовая частота процесса
Помогите плиз срочно

Прямо сейчас

получается я пишу в одной ячейке месяц а рядом мне должно выдавать такие слова как: сессия, занятия, каникулы. Всё должно быть так 1 и 6 сессия, 7 и 8

каникулы, всё остальное занятия. Должно быть всё примерно так, но я не пойму в чём проблемма(=ЕСЛИ(МЕСЯЦ(A1)=ИЛИ(1;6);"сессия";ЕСЛИ(A1=ИЛИ(7;8);"каникулы";"занятия")), баллов даю много так что постарайтесь. Удачи!!!

Читайте также

ТЕМА: МАССИВЫ

помогите плиз!

Написать программу расчета среднего арифметического отрицательных элементов в одномерном массиве. Заменить минимальный элемент в одномерном массиве на полученное среднее арифметическое.

Тема "Массивы" 10 класс

Друзья я ноль в информатике, помогите пожалуйста.
Буду очень благодарна. :)

Паскаль, составьте программу для двумерного массива:

Найти произведение отрицательных элементов указанной строки двумерного массива размером 4*5 целых чисел.



Вы находитесь на странице вопроса "Тема "Массивы и двумерные массивы"", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.