Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Даны два целых числа А и В (А<В). Найти сумму всех целых чисел от А до В включительно Входные данные: ввести два целых числа А,В (1<=A,

10-11 класс

B<=100).

Выходнфе данные: вывести сумму всех целых чисел от А до В включительно.

Можно, пожалуйста, с объяснением.

Gulnazik12345 20 февр. 2014 г., 16:37:50 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kip1272
20 февр. 2014 г., 19:25:50 (10 лет назад)

var

  sum, a, b, i : integer;

begin

  read (a, b);

  sum := 0;

  for i := a to b do //Бежим по всем числам от а до б

    sum := sum + i; //и прибавляем каждое число к сумме

  writeln (sum);

end.

+ 0 -
Chaas
03 июля 2016 г., 5:32:26 (7 лет назад)

No quoteisn this is the place to get this info, thanks y'all.

+ 0 -
Sonny
04 июля 2016 г., 15:04:03 (7 лет назад)

A minute saved is a minute eadnre, and this saved hours!

Ответить

Другие вопросы из категории

Pascal ABC Операторы case of ; if then else ; for to do;

Помогите написать программы..........................................................................................
................................................. которые находятся в файле

Для построения сети с топологией "звезда" обычно применяется...

1) ...коаксиальный кабель, коннекторы и терминаторы

2) ...кабель "витая пара" и концентратор (Hub)

3) ...оборудование стандарта Token Ring

4) все ответы верны

Читайте также

Даны два целых числа A и B (A < B). Вывести в

порядке возрастания все целые числа, расположенные между A и B(в том числе A и B),
a также количество N этих чисел
ЦИКЛ с ПАРАМЕТРОВ

. Даны два целых числа A и B

(A < B). Найти произведение всех целых чисел от A до B
включительно.

1)По данному числу n вычислите сумму 2(1-1/3+1/5-1/7+...+(-1)n/(2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000.

Формат выходных данных: Необходимо вывести значение выражения 2) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b,не дающие остаток c при делении на d 3) Подсчитайте, сколько среди данных N чисел нулей, четных чисел, нечетных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число четных и нечетных чисел 4) электронное устройство, выдает каждую секунду очередное число последовательности 1, 2, 2, 3, 3, 3, 4, 4, 4, 4, 5... Ввиду дороговизны электронных комплектующих вам поручено разработать эмулятор для этого устройства. Формат входных данных: Дано количество секунд (от 1 до 1000000), которые работает генератор после включения. Формат выходных данных: Результат работы генератора(пример 2 1 2 5 1 2 2 3 3) 5)Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число 6)Исполнитель “Раздвоитель” преобразует натуральные числа. У него есть две команды: “Вычесть 1” и “Разделить на 2”, первая команда уменьшает число на 1, вторая команда уменьшает число в два раза, если оно чётное, иначе происходит ошибка.Дано два натуральных числа A и B (A>B). Напишите алгоритм для Развоителя, который преобразует число A в число B и при этом содержит минимальное число команд. Команды алгоритма нужно выводить по одной в строке, первая команда обозначается, как -1, вторая команда как :2.

1) Составить функцию, которая определяет наибольшее из трех чисел и привести пример ее использования. Пример: Введите три числа:

28 15 10

Наибольшее число: 28

2)Составить функцию, которая определяет сумму всех чисел от 1 до N и привести пример ее использования.

Пример:

Введите число:

100

Сумма = 500

Буду очень признателен за помощь.

Даны два целых

числа A и B (A < B). Вывести все целые числа,
расположенные между данными числами (включая сами эти числа), в порядке их
возрастания (убывания), а также количество N этих чисел (с использованием
оператора for, while, repeat)



Вы находитесь на странице вопроса "Даны два целых числа А и В (А&lt;В). Найти сумму всех целых чисел от А до В включительно Входные данные: ввести два целых числа А,В (1&lt;=A,", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.