Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

у мя паскаль, Составьте программу,которая формируется массив из шестнадцати случайных целых чисел от -20 до 20 и:находить элементы с нулевыми

10-11 класс

значениями.

Kukai 28 апр. 2015 г., 3:49:12 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Danil1412
28 апр. 2015 г., 5:52:33 (9 лет назад)

program ask_1;
const k = -20;
         b = 20;
type MyArray = Array[1..16]of integer;
var A:MyArray;
     i:integer; //
begin
Randomize;
for i:=1 to 16 do begin
A[i] := random(b-k+1);
if (A[i] = 0) then write(i);
end;
end.
Поскольку в задании не сказано вывести данный массив, то в этой программе выводятся элементы с 0 значением.

Ответить

Другие вопросы из категории

фастом фастом!!!!!!!!!!!!!!!!!!!
Производится одноканальная (моно) звукозапись с частотой дискретизации 22 кГц и глубиной кодирования 16 бит. Запись длится 2 минуты, ее результаты

записываются в файл, сжатие данных не производится. Какое из приведенных ниже чисел наиболее близко к размеру полученного файла, выраженному в мегабайтах?

Введите

с клавиатуры целое число. Выведите на экран следующие число, удвоенное
значение числа, противоположное число, модуль числа, квадрат числа.


Читайте также

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

Люди помогайте!!!))) Паскаль!!!

1)Составьте программу, которая заполняет массив 10-ю случайными целыми числами в диапазоне [1..20] и выводит на экран элементы массива в нечетными значениями.

2)Составьте программу заполнения массива из десяти чисел следующими значениями
а) 2 4 6 8 10 (+ 2)
б)3 6 9 12 15 (+3)



Вы находитесь на странице вопроса "у мя паскаль, Составьте программу,которая формируется массив из шестнадцати случайных целых чисел от -20 до 20 и:находить элементы с нулевыми", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.