Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите решить задачу на паскале: в двумерном массиве хранятся результаты (время в минутах), показанные каждым из 12 автогонщиков на каждом из

10-11 класс

10 этапов соревнований «Формула-1». После 10 этапа участник с порядковым номером 4 выбыл из соревнований. Изменить массив так, чтобы в нем не было результатов бывшего гонщика.

Artemw2003 25 февр. 2014 г., 19:21:38 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
13121
25 февр. 2014 г., 21:10:34 (10 лет назад)

var
  i,j:integer;
  a:array[1..12,1..10]of integer;
begin
writeln ('Исходная таблица: ');
for i:=1 to 12 do
  begin
  for j:=1 to 10 do
    begin
    a[i,j]:=50+random(10);
    write(a[i,j]:3);
    end;
  writeln;
  end;
writeln;
for i:=5 to 12 do
  for j:=1 to 10 do
    a[i-1,j]:=a[i,j];
for j:=1 to 10 do a[12,j]:=0;
writeln ('Измененная таблица: ');
for i:=1 to 11 do
  begin
  for j:=1 to 10 do
    write(a[i,j]:3);
  writeln;
  end;
end.

+ 0 -
Intizarkaa
25 февр. 2014 г., 22:56:33 (10 лет назад)

"не было" - это заменить их на нули? Или сдвинуть, перенести на их место следующие значения массива?

+ 0 -
Sauron21
26 февр. 2014 г., 0:59:48 (10 лет назад)

сдвинуть, перенести на их место следующие значения массива

Ответить

Другие вопросы из категории

Дан прямоугольный массив целых положительных чисел 10 х 20. Опишите на русском языке или на одном из языков программирования алгоритм поиска строки с

наименьшей суммой элементов. Вывести на печать номер строки и сумму ее элементов. Предполагается, что такая строка единственна.

помогите пожалуйста составить программу в Паскале!!

1.чему равна сумма десятичного числа10 и двоичного числа 10 в десятичной системе счисления

1)20
2)12
3)21
4)1010
число 12 десятичной системы счисления в двоичной системе счисления имеет вид:
1)1000
2)1011
3)0010
4)0100
5)1100

Читайте также

Пожалуйста,помогите решить задачи на Pascale!

1)Составить программу вычисления в двумерном массиве минимального элемента, его номера и замены его на 100
2)Записать в файл последовательность доступа n действительных чисел. Найти разность первого и последнего компонентов файла
3)Составить программу, удаляющую из предложения букву "Е"

Помогите решить задачу на Паскале.

Дана строка.Перенести последнюю букву слова в начало слова

Помогите решить задачу на паскале, очень нужно:

Дана строка, удалить текст находящийся в скобках (вместе со скобками)

Я тут начал делать, вот только с удалением у меня ничего не получается, напишите как можно сделать

Вот как я делал:
program zd;
uses crt;
var s:string; i,l,n,t,y:integer;
begin
clrscr;
writeln('Введите строку');
readln(s);
l:=length(s);
for i:=1 to n do begin
if s[i]='(' then
t:=i; {здесь присваивал номер найденной скобки}
if s[i]=')' then
y:=i; {так же, как и выше}
delete (s,t,i); {у меня получается, что он удаляет с открывающей скобки и всё что находится вправо, а левая часть до скобки остается нетронутой}
end;
writeln('Данный результат =', s);
readln;
end.



Вы находитесь на странице вопроса "Помогите решить задачу на паскале: в двумерном массиве хранятся результаты (время в минутах), показанные каждым из 12 автогонщиков на каждом из", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.