Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Написать программу которая может вычислить стоимость покупки с учетом скидки 10% есть сумма покупки больше 1000р

5-9 класс

Ang177 03 дек. 2014 г., 18:41:39 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
маша338
03 дек. 2014 г., 20:34:43 (9 лет назад)

var
  a: real;
  
begin
  while a <= 1000 do
  begin
    writeln('Введите сумму покупки > 1000р');
    readln(a);
    if a > 1000 then break
    else writeln('Ошибка! Введенная сумма покупки <= 1000p');
  end;
  writeln('Стоимость покупки с учетом скидки 10%:  ', a * 0.9);
end.
Данная программа проверяет, больше 1000 или нет, введенная стоимость покупки. Можно сделать проще без проверки:
var
  a: real;
  
begin
  writeln('Введите сумму покупки > 1000р');
  readln(a);
  writeln('Стоимость покупки с учетом скидки 10%:  ', a * 0.9);
end.

Ответить

Другие вопросы из категории

а) Самый первый инструмент хранения информации.

б) Собственная (внутренняя) память человека.
в) Внешняя память- записные книжки,справочники и тд
г) Любой материальный объект,используемый для фиксации и хранения информации.4



(не A Или B →C) &(⌐A→⌐C)=1

Сколько решений имеет уравнение?

Читайте также

Определить стоимость покупки с учетом скидки . Скидка в 10% предоставляется если сумма покупки больше 1000 рублей. Входные данные S-стоимость покупки.

ВХОДНЫЕ ДАННЫЕ S- стоимость покупки с учетом скидки( если она предоставляется)

Помогите плиз срочно 1)Написать программу,которая спрашивает"Который час?" и,в зависимости от введенного времени,выводит приветствие:"Доброе

утро","Добрый день","Добрый вечер", "Спокойной ночи". 2)Написать программу,которая определяет,принадлежит ли точка с координатами (x,y)Заштрихованной области,ограниченной точками(x1,y1)(x2,y2).

Пожалуйста помогите решить желательно все или хотя бы одну (P.S. программа для программы Turbo Pascal) 1.Написать программу, которая предлагает

ввести 3 значное число и находит сумму его цифр.

2. Написать программу, которая предлагает ввести 3 значное число и меняет порядок цифр наоборот. (123- 321)

3.Написать программу, которая предлагает ввести три числа с клавиатуры, находит их сумму, произведение и среднее арифметическое.

Паскаль абс 2 задачи 1)Написать программу выводящую на экран последовательность чисел от 1 до 10 через пробел в строчку.

2)Написать программу которая бы выводила на экран произведение нечетных чисел от 10 до 20.



Вы находитесь на странице вопроса "Написать программу которая может вычислить стоимость покупки с учетом скидки 10% есть сумма покупки больше 1000р", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.