Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите пожалуйста написать программу! Найти количество натуральных чисел, произведение которых не превышает 1000.

10-11 класс

ДДДДДДДДДДДДДДДДД 21 июня 2013 г., 13:23:08 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
МиракоЧан
21 июня 2013 г., 15:40:27 (10 лет назад)

Если я все правильно понял, и нужно найти кол-во пар чисел, произв которых не превышает 1000, то вот решение, если неправильно, напиши сообщение, исправлю

 

var
 i, j, ans: integer;

begin
 ans := 0;
 for i := 1 to 1000 do
 for j := 1 to (1000 div i) + 1 do if i * j < 1000 then ans := ans + 1;
 writeln(ans);
end.

Ответить

Другие вопросы из категории

Какова мощность алфавита, если информационный вес одного символа составляет 32 бита? При приеме некоторого сообщения получили 10 бит информации.

Сколько вариантов исхода было до получения сообщения? Объем сообщения, содержащего 2048 символов, составил 1/512 часть Мбайта. Каков размер алфавита, с помощью которого записано сообщение? Выяснить, сколько бит информации несет каждое двухзначное число (отвлекаясь от его конкретного числового значения). В книге 512 страниц. Сколько информации содержит сообщение о том, что закладка лежит на какой-либо странице. Для ремонта школы использовали белую, синюю и коричне¬вую краски. Израсходовали одинаковое количество банок белой и синей краски. Сообщение о том, что закончилась банка белой краски, несет 2 бита информации. Синей краски израсходовали 8 банок. Сколько банок коричневой краски израсходовали на ремонт школы? Определить количество информации, получаемое при реализации одного из событий, если бросают несимметричную четырехгранную пирамидку.

Сколько раз выполнится цикл:

for (int i=0; i<=6; i++)
cout < < i < < endl;

помогите пожалуйста разобраться с заданием:

Составьте программу в кумире "таблица умножения на 7"

Читайте также

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

помогите пожалуйста сделать=)))

а) Написать программу, определяющую среднее арифметическое всех чисел от 0 до заданного пользователем.

б)Написать программу, определяющую количество четных чисел от 0 до заданного пользователем числа.

ПОМОГИТЕ ПОЖАЛУЙСТА! ОЧЕНЬ НУЖНО!( 1)Осуществите циклический сдвиг компонент заданного вектора A(N) влево на одну

позицию, то есть получите вектор А = (a2 , a3 , ..., aN , a1 ).

2) Имеется последовательность чисел a1, a2 , ..., aN . Найти сумму первых из них, произведение которых не превышает заданного числа М.

СИ++. #include <stdio.h>

#include <conio.h>

1. Дано n чисел. Найти колличество тех, которые делятся на 5, и не делятся на 7.

2. Найти квадраты всех отрицательных чисел среди N заданных.
3. Найти количество чисел, среди N введенных,которые имеют нечетные порядковые номера, а сами являются четными числам.
4. напишите программу для вычисления суммы:
- 1*1!+2*2!+3*3!+....+n*n!
- 1*3+3*5+5*7+...n(n+2)
- 1+11+111+...+111+1-n слагаемых.
Помогите, пожалуйста написать программы для паскаля, очень нужно. Заранее спасибо.



Вы находитесь на странице вопроса "Помогите пожалуйста написать программу! Найти количество натуральных чисел, произведение которых не превышает 1000.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.