Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дан массив из 20 чисел. найти среднее арифметическое. найти наименьший элемент методом бинарного поиска. (Pascal)

10-11 класс

Tatach2003 19 нояб. 2013 г., 23:14:46 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
GysevaOlga84
20 нояб. 2013 г., 1:21:33 (10 лет назад)

var

  m : array [1..20] of Integer;

  s : Real;

  i : Integer;

begin

 

  s := 0;

  for i := 1 to 20 do

    s := s + m[i];

  

  s := s / 20;

 

  Writeln('Cреднее арифметическое = 

Ответить

Читайте также

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от -100 до 100. Напишите программу, которая позволит

подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. №2. Дан массив из 40 элементов. Каждый элемент может принимать целочисленные значения от 0 до 200. Напишите программу, которая позволит найти наиболее часто встречающийся элемент массива

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.

Добрый день. Помогите пожалуйста решить две задачи... №1 Дан массив из 25 элементов,найти сумму 4-х наибольших и 4-х наименьших э

лементов. Результат распечатать в виде:

Сумма наибольших=

Сумма наименьших=

№2

Даны два массива по 30 элементов. Найти среднее арифмитическое для элементов 1-го массива,номера которых больше номера минимального элемента 2-го массива

Заранее спасибо

ЛЮДИ, ПОМОГИТЕ, ПОЖАЛУЙСТА Сформировать одномерный массив из 20 элементов (значения элементов задаются случайным образом). Вывести массива на

экран. Найти среднее арифметическое элементов первой половины массива и сумму элементов второй половины массива.

паскаль массивы



Вы находитесь на странице вопроса "Дан массив из 20 чисел. найти среднее арифметическое. найти наименьший элемент методом бинарного поиска. (Pascal)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.