Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

помогите написать 2 легкие программки на паскале, скрины внутри

10-11 класс

Алекса067 03 июня 2013 г., 3:22:25 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Gagamonster
03 июня 2013 г., 5:27:06 (10 лет назад)

первая
r1, u1, r2, u2:integer;
a1, a2:real;
begin
readln(r1, r2, u1, u2);
a1:=u1\r1;
a2:=u2\r2;
if a1<a2 then writeln('a1')
else writeln('a2');
readln;
end.
вторая
s:string;
i, k, n, j:integer;
begin
readln(s);
for i:=1 to length(s) do begin
for j:=1 to length(s) do
if s[i]=s[j] then k:=k+1;end;{ здесь begin может стоять или не стоять. зависит от версии pascal}
if k>4 then writeln('no')
else writeln('yes');
readln;
end.

Ответить

Читайте также

Помогите написать программу по Информатике! Найти произведение двузначных нечетных чисел, кратных

13.

Нужно написать программу на цикле с предусловием, на Паскале.

1. Написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов.

2. Написать прогрумму,которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.



Вы находитесь на странице вопроса "помогите написать 2 легкие программки на паскале, скрины внутри", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.