Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

В небоскрёбе n этажей и 1 подъезд,на каждом этаже по 3 квартиры,лифт останавливается только на не чётных этажах .Человек садится в лифт и нажимает номер

5-9 класс

нужной ему квартиры.На какой этаж дома довезёт лифт человека.
(в паскале) плиззз помогите срочно надо

CROuNo 03 февр. 2014 г., 2:20:43 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kaikhatsu
03 февр. 2014 г., 4:21:27 (10 лет назад)

Program Zadacha;
Const k = 3;
Var n, e, rd, rm: Integer;
Begin
Write('n = ');
ReadLn(n);
WriteLn('Какой номер квартиры нужен человеку?');
ReadLn(e);
rd := e Div 3;
rm := e Mod 3;
If rm > 0 Then
rd := rd + 1;
If rd > n Then
WriteLn('Такой квартиры не существует')
Else
Begin
If rd Mod 2 = 0 Then
If (rd + 1) < n Then
rd := rd + 1
Elser
d := rd - 1;
WriteLn('Лифт довезёт человека на ', rd, ' поверх');
End;
ReadLn;
End.

+ 0 -
Zhenyamil2
03 февр. 2014 г., 7:02:26 (10 лет назад)

блин мне кто нибудь поможет

+ 0 -
алинаС13
03 февр. 2014 г., 8:56:00 (10 лет назад)

аааа???

+ 0 -
TheVitalina
03 февр. 2014 г., 11:08:59 (10 лет назад)

var
n, flat, floor: Integer;

begin
Write('n = ');
ReadLn(n);
WriteLn('Какой номер квартиры нужен человеку?');
ReadLn(flat);
floor := (flat - 1) div 3 + 1;
if (floor > n) or (flat <= 0) then begin
writeln('Не верный номер квартиры');
exit;
end;
if (floor mod 2 = 0) or (floor = 1) then
writeln('Едем на ', floor, ' этаж')
else
writeln('Едем на ', floor - 1, ' этаж');

end.

Ответить

Читайте также

Текст рассказа набран на компьютере. Информационный объём получившегося файла 9 Кбайт. Текст занимает 6 страниц, на каждой странице одинаковое количество

строк, в каждой строке 48 символов. Все символы представлены в кодировке КОИ-8, в которой каждый символ кодируется 8 битами. Определите, сколько строк помещается на каждой странице

1. В кодировке Unicode на каждый символ отводится два байта. Определите информационный объем слова из двадцати четырех символов в этой кодировке.

2.​ Мощность
алфавита равна 256. Сколько кбайт памяти потребуется для сохранения 160
страниц текста, содержащего в среднем 192 символа на каждой странице?

Племя Пульти пользуется 64- символьным алфавитом. Свод основный знаков племени хранится на 1024 глиняных табличках, на каждую из которых нанесено ровно

512 символов. Какой объем информации содержится на каждом носителе ? Сколько информации заключено во всем своде законов ?

На каждой из трех осей установлено по одной вращающейся шестеренке и неподвижной стрелке. Шестеренки соединены последовательно. На первой шестеренке 33

зубца, на второй - 10, на третьей - 7.На каждом зубце первой шестеренки по часовой стрелке написано по одной букве русского языка в алфавитном порядке: А Б В Г Д Е Ё Ж З И Й К Л М Н О П Р С Т У Ф Х Ц Ч Ш Щ Ъ Ы Ь Э Ю Я На зубцах второй и третьей шестеренки в порядке возрастания по часовой стрелке написаны цифры от 0 до 9 и от 0 до 6 соответственно.Когда стрелка первой оси указывает на букву, стрелки двух других осей указывают на цифры. Буквы сообщения шифруются последовательно. Шифрование производится вращением первой шестеренки против часовой стрелки до первого попадания шифруемой буквы под стрелку. В этот момент последовательно выписываются цифры, на которые указывают вторая и третья стрелки. В начале шифрования стрелка 1-го колеса указывала на букву А, а стрелки 2-го и 3-го колес - на цифру 0. Следовательно, шифр буквы А - 0 0.Вам предстоит зашифровать слово - О Л И М П И А Д А.В ответе укажите через пробел 18 цифр - каждая пара соответствует коду буквы на второй и третей шестеренке соответственно.



Вы находитесь на странице вопроса "В небоскрёбе n этажей и 1 подъезд,на каждом этаже по 3 квартиры,лифт останавливается только на не чётных этажах .Человек садится в лифт и нажимает номер", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.