РЕБЯТУШКИ! КТО СИЛЕН В ИНФОРМАТИКЕ ,ПОМОГИТЕ) Какое значение будет принимать переменная x,после выполнения фрагмента программы: f=5; d-7; if f>=d then
5-9 класс
|
x=f else x=d ЗАРАНЕЕ СПАСИБО)
![](https://avatar.neparsya.net/avatar/10719.gif)
![](https://avatar.neparsya.net/avatar/5176.gif)
Ответ: 7
// Решение должно иметь от 20 до 5000 символов
Другие вопросы из категории
наибольшим из них и выведите результаты на экран. Иначе, найдите и выведите сумму квадратов этих чисел.
Читайте также
integer;
Begin
Y:=0;
For x:=1 to 9 do
Y:=y+1;
Writeln (‘y = ’,y);
End.
2) Var
Y, x: integer;
Begin
Y:=0;
X:=10;
While x>0 do
Begin
X:= x-2;
Y:= y+x;
End;
Writeln (‘y = ’,y)
End.
3*b end. вот варианты ответов : а) 9 б)7 в)12 г) -7
if A>B then S: = A+B;
writeln (S);
Варианты ответов:1)5 ;2)6; 3)7; 4)8
2. Какое значение переменной S будет напечатано после выполнения фрагмента программы, записанной на языке программирования PASCAL:
S: =1;
N: =1;
while N<=3 do
begin
S: = S*N;
N: = N+1;
end;
writeln(S);
Варианты ответов: 1)2 ; 2)1; 3)0; 4)4
(a div 10) + 14;
a := (b mod 10) + 2;
2) Определите значение целочисленных переменных a и b после выполнения фрагмента программы:
a := 1819;
b := (a div 100)*10+9;
a := (10*b–a) mod 100;
3) Определите значение целочисленных переменных a и b после выполнения фрагмента программы:
a := 42;
b := 14;
a := a div b;
b := a*b;
a := b div a;
4) Определите значение целочисленных переменных x, y и t после выполнения фрагмента программы:
x := 5;
y := 7;
t := x;
x := y mod x;
y := t;
5) Определите значение целочисленных переменных a и b после выполнения фрагмента программы:
а :=6*12 + 3;
b :=(a div 10)+ 5;
a :=(b mod 10)+ 1;