Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Pascal.

5-9 класс

Даны три переменные вещественного типа: A, B, C. Если их значения упо- рядочены по возрастанию или убыванию, то удвоить их; в противном слу- чае заменить значение каждой переменной на противоположное. Вывести новые значения переменных A, B, C.

AnitaPodles 24 окт. 2014 г., 21:16:07 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vika555999
24 окт. 2014 г., 23:22:26 (9 лет назад)

var
  a, b, c: real;

begin
  Write('Введите через пробел три числа -> ');
  Readln(a, b, c);
  if ((a > b) and (b > c)) or ((a < b) and (b < c)) then
  begin a := 2 * a; b := 2 * b; c := 2 * c end
  else
  begin a := -a; b := -b; c := -c end;
  writeln('Новые значения чисел: ', a, ', ', b, ', ', c)
end.

Тестовое решение:

Введите через пробел три числа -> 18 5 -3
Новые значения чисел: 36, 10, -6

Введите через пробел три числа -> -6 0 5
Новые значения чисел: -12, 0, 10

Введите через пробел три числа -> 11 20.7 4.9
Новые значения чисел: -11, -20.7, -4.9





+ 0 -
Milena0919
25 окт. 2014 г., 0:19:36 (9 лет назад)

На противоположное - это поменять знак?

+ 0 -
Алиночка1122
25 окт. 2014 г., 3:16:02 (9 лет назад)

Ответа нет, будем считать, что так

Ответить

Другие вопросы из категории

10я - 4; 2я - ?; 8я-?; 16я-?; сумма - 100+1100=?; разность-1100-100=?;

10я- 19; 2я-?; 8я-?; 16я-?; сумма- 10011+ 111001=?; разность 111001-10011=?; 10я-34; 2я-?; 8я-?; 16я-?; сумма-10010+1100110=?; разность-1100110-100010=? 10я-49; 2я-?; 8я-?; 16я-?; сумма-110001+10010011=?; разность-10010011-110001=?;
10я-64; 2я-?; 8я-?; 16я-?; сумма 1000000+11000000=? разность-11000000-1000000=?

блин люди да помогиет мне с задачами

1) в книге 150 страниц по 40 строк и 60 символов обьем книги выразить в мегабайтах
2) дано 5 учебников их вес 350кб найти вес 1 учебника в байтах
пожалуста все подробно кто решит все правильно сдеалю лучший

Помогите пожалуйста!!!!!

1) Основное устройство ввода информации
2)"Мозг" компьютера
3)Устройство вывода информации
4)Устройство хранения программ и данных
5)Устройство для быстрого перемещения по экрану
6)Носитель информации, на которой записывают программы для хранения
7)Другое название жесткого диска
8)Устройство, с помощью которого можно вывести на бумагу тексты и рисунки

Читайте также

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу,которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.


1.Какое значение переменной S будет напечатано после выполнения фрагмента программы,записанной на языке программирования TURBO PASCAL:A:=2В: = 3;

if A>B then S: = A+B;
writeln (S);
Варианты ответов:1)5 ;2)6; 3)7; 4)8

2. Какое значение переменной S будет напечатано после выполнения фрагмента программы, записанной на языке программирования PASCAL:
S: =1;
N: =1;
while N<=3 do
begin
S: = S*N;
N: = N+1;
end;
writeln(S);
Варианты ответов: 1)2 ; 2)1; 3)0; 4)4

1) дано четырёхзначное число. вывести максимальную и минимальную цифру. pascal abc

2) дано четырёхзначное число. Что больше: произведение цифр числа или их утроенная сумма. pascal ABC



Вы находитесь на странице вопроса "Pascal.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.