Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите! Нужно решение. Ввод натурального числа и вычисление значения его факториала

5-9 класс

гпврнгопарл 22 мая 2014 г., 14:53:39 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Radusiii
22 мая 2014 г., 16:15:38 (9 лет назад)

Pascal

var
 n,fact,i:Integer;
 Begin
  Read(n);
  fact:=1;
  for i:=1 to n do
   fact:=fact*i;
  Writeln(fact);
 end.

Ответить

Другие вопросы из категории

Какой объём информации несёт в себе сообщение занимающее 3 страницы , по 25 строк, по 80 символов , 20-ти символьного алфавита?

Для записи текста использовался 256-ти символьный алфавит.Каждая страница содержит 30 строк , по 70 символов.Какой объём информации содержат пять страниц теста?

Заранее спасибо.:)

Помогите, пожалуйста! НА ЗАВТРА!!!!!

номер 2,3,4,5,6!!

Читайте также

Автоморфные числа. Натуральное число называется автоморфным, если оно равно последним цифрам его квадрата. Например: 25^2=625. Напишите программу, которая

вводит натуральное число N и выводит на экран все автоморфные числа, не превосходящие N.

1.С клавиатуры вводится действительное число a.Найти его квадратный корень.

2.С клавиатуры вводится действительное число p.Записать отдельно его целую часть C.
Помогите составить программу.

задача 1. Дано натуральное число n. Напишите программу выводящую на экран последовательность натуральных чисел от 1 до n. задача 2. Даны

натуральные числа A , B, где B>A. Напишите программу последовательность натуральных чисел от A до B, включающая A и B.

Пожалуйста помогите !!!!!!!!

1)найти количесво делителей натурального числа,сколько из них чётных? 2) дано натуральное число: найти две первые цыфры числа

верно ли,что первая цыфраа данного числа чётная?

3)найти все трёхзначные числа,которые состоят из разных цыфр,а их сумма равна А(А вводится с клавиатуры)

4)найти все симметричные натуральные числа(палиндромаиз промежутка от А до В(А и В вводится с клавиатуры)

дано натуральное число N, Написать ему выводящую на экран последовательность натуральность натуральных чисел от 1 до N, задание 2 дано натуральное число

N, Написать ему выводящую на экран последовательность натуральность натуральных чисел отN до 1, номер 3 Даны натуральные числа N и К.Написать программу выводящую на экран последовательность из N чисел , каждое из которых равно К хотя бы что нибудь решите помогите очень надо!!!!!!!!!



Вы находитесь на странице вопроса "Помогите! Нужно решение. Ввод натурального числа и вычисление значения его факториала", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.