Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Тема: Одномерные массивы.

10-11 класс

Задание 22.
Написать в паскале программу.
http://cs540108.vk.me/c624831/v624831678/e2e5/T8n_Z6B_4MU.jpg

Karanfil 25 янв. 2017 г., 4:35:00 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ЕлизаветаS2S
25 янв. 2017 г., 7:18:42 (7 лет назад)

uses crt;
var s,i:integer;
a:array [1..8] of integer;
begin
writeln ('заполните массив ');
for i:=1 to 8 do begin
write ('Введите a[',i,'] элемент: ');
readln (a[i]);
s:=s+i*a[i];
end;
writeln ('сумма = ',s);
end.

Ответить

Другие вопросы из категории

что не так в моей задаче по Паскалю?

Program A;
Var z,b,i:integer;
begin randomize;
z:=randon(16);
b:=randon(16);
i:=randon(16);
writeln('z=',z,'b=',b,'i=',i);
if (z>b) and (b>i) then writeln('z=',z,'b=',b,'i=',i);
if (z>i) and (i>b) then writeln('z=',z,'i=',i,'b=',b);
if (zz) and (bi) and (i>z) then writeln('b=',b,'i=',i,'z=',z);
if (bi) then writeln('z=',z,'i=',i,'b=',b);
readln(z,b,i);
end.

Читайте также

Ребят, помогите! Тема: одномерные массивы. Две задачи:1) Написать прог

Ребят, помогите! Тема: одномерные массивы. Две задачи:

1) Написать программу, которая из заданного одномерного массива размерности N находит сумму только тех элементов, значения которых больше некоторого значения S.
S=5; Массив: 0,4 5,6 -2 10,1


2) При поступлении в ВУЗ абитуриенты, получившие "Двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны оценки экзаменующихся, полученных на первом экзамене. Подсчитать, сколько человек не допущено ко второму экзамену!

Заранее благодарю!

Составить блок-схему алгоритма и программу на алгоритмическом языке программирования БЕЙСИК обработки одномерного массива. Заполнение массива элементами

организовать путем ввода с клавиатуры. В одномерном массиве из N натуральных чисел вычислить сумму удвоенных четных чисел.

Помогите составить блок-схему алгоритма и программу на алгоритмическом языке программирования БЕЙСИК обработки одномерного массива.Заполнение массива

элементами организовать путем ввода с клавиатуры.В одномерном массиве из N чисел вывести на экран отрицательные элементы и сообщите об их количестве.Пожалуйста,срочно надо.

1.В произвольно заданном одномерном массиве ( случайные значения из отрезка -6 до 11 ) из 6 элементов, определить количество отрицательных, нулевых и

положитльных элементов.
2.
Сформируйте одномерный массив из 5 элементов (значения элементов укажт пользователь с клавиатуры). Обнулите значения всех элементов с нечетными индексами. Выведите значения одномерного массива в строку через пробел.

Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом

массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию



Вы находитесь на странице вопроса "Тема: Одномерные массивы.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.