Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

підрахувати суму всіх натуральних чисел, які діляться на 3 і не перевищють деякого числа N. паскаль, цикл for. думаю, будет примерно

5-9 класс

так:

program zad;

var i,r,n:integer;

begin

writeln ('введіть число n');

readln(n);

for i:=i<n and (i mod 3=0) do

begin writeln (r:=...);

end;

readln;

end.

не знаю как найти сумму

Tamaradc 10 июня 2013 г., 7:22:18 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ВАШКА95
10 июня 2013 г., 8:00:06 (10 лет назад)

Решалось примерно следующим образом:

Объявить две переменные для числа n и суммы чисел. А хотя нет. Надо три(ещё управляющая переменная для for)

Ввести число n

Зная, что натуральные числа - это все числа от единицы, создаём цикл for с таким условием: управляющая переменная i = 1, i < n i++(увеличить на 1)

(на паскале будет примерно так:

for i := 1 to (n - 1) do

   begin

      ................

   end;

)

Далее в теле цикла сделать условие: если i делится без остатка, то прибавить это число к переменной для суммы чисел(которая в начале равна 0)

Ну и в конце вывести сумму.

 

Вот вариант на C++

 

#include <iostream>
using std::cout;
using std::cin;
using std::endl;

int main()
{
   int n, total = 0;

   cout << "Enter the number: ";
   cin >> n;

   for(int i = 1; i < n; i++)
   {
      if(i % 3 == 0)
      {
         total += i;
      }
   }

   cout << "Sum = " << total << endl;

   cin.get();
   return 0;
}

 

Вроде и на Паскале получилось:

 

program test;
var i, n, total:integer;
begin
  write('Enter n: ');
  readln(n);
  total := 0;
  for i := 1 to (n - 1) do
  begin
    if i mod 3 = 0 then
    total := total + i;
  end;
  writeln('sum = ', total);
readln();
end.

Ответить

Другие вопросы из категории

автомобиль проехал три участка пути разной длины с разными скоростями.

найдите среднюю скорость автомобиля

помогите ребята срочно
Два сообщения содержат одинаковое количество символов. Количество информации в первом тексте в 2,5 раза меньше, чем во втором. Сколько символов

содержат алфавиты, с помощью которых записаны сообщения, если известно, что размер каждого алфавита не превышает 32 символов и на каждый символ приходится целое число битов?

в видео проекторах не требуется

а) линза
б) фотобарабан
в) источник света
г) кулер

Читайте также

задача 1. Дано натуральное число n. Напишите программу выводящую на экран последовательность натуральных чисел от 1 до n. задача 2. Даны

натуральные числа A , B, где B>A. Напишите программу последовательность натуральных чисел от A до B, включающая A и B.

Пожалуйста помогите !!!!!!!!

дано натуральное число N, Написать ему выводящую на экран последовательность натуральность натуральных чисел от 1 до N, задание 2 дано натуральное число

N, Написать ему выводящую на экран последовательность натуральность натуральных чисел отN до 1, номер 3 Даны натуральные числа N и К.Написать программу выводящую на экран последовательность из N чисел , каждое из которых равно К хотя бы что нибудь решите помогите очень надо!!!!!!!!!

Напишите программу, которая подсчитывает количество двузначных чисел в заданной последовательности натуральных чисел.Программа получает на вхо

д количество чисел в последовательности, а затем сами числа.Количество чисел не превышает 1000. Введённые числа не превышают 30 000.Программа должна вывести одно число – количество двузначных чисел в заданной последовательности натуральных чисел.

1, С клавиатуры вводятся 10 натуральных чисел. Вычислить сумму четных элементов.

2, С клавиатуры вводятся 15 натуральных чисел. Подсчитать количество элементов, кратных 3 и 5.
3, С клавиатуры вводятся 10 натуральных чисел. Вычислить произведение чисел, больших 10, но меньших 20.

1, С клавиатуры вводятся 10 натуральных чисел. Вычислить сумму четных элементов.

2, С клавиатуры вводятся 15 натуральных чисел. Подсчитать количество элементов, кратных 3 и 5.
3, С клавиатуры вводятся 10 натуральных чисел. Вычислить произведение чисел, больших 10, но меньших 20.



Вы находитесь на странице вопроса "підрахувати суму всіх натуральних чисел, які діляться на 3 і не перевищють деякого числа N. паскаль, цикл for. думаю, будет примерно", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.