Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

построить алгоритм трех задач.

10-11 класс

Tarapulya21 27 февр. 2017 г., 19:14:00 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mashaolivko
27 февр. 2017 г., 21:07:11 (7 лет назад)

1) 1.начало
2.пока впереди есть свободная клетка
3.начало цикла
4.идти вперёд на 1 клетку
5.закрасить клетку
6.конец цикла
7.повернуться на 90 градусов против часовой стрелки
8.пока  клетка!=клетке А повторить действия 2-7
9.конец.
2) 1.начало
2.пока впереди есть свободная клетка
3.начало цикла
4.идти вперёд на 1 клетку
5.закрасить клетку
6.конец цикла
7.повернуться на 90 градусов по часовой стрелке
8.пока впереди есть свободная клетка 
9.начало цикла
10.идти вперёд на 1 клетку
11.закрасить клетку
12.конец цикла
13.повернуться на 90 градусов против часовой стрелки
14.пока клетка!=клетке А
15.начало цикла
16.идти вперёд
17.закрасить клетку
18.конец цикла
3)
начало
пока робот не напротив стены идти вперёд;
закрасить клетку
начало повтора
пока впереди под стеной есть клетки
начать цикл
идти вперёд
закрасить клетку
закончить цикл
повернуться на 90 градусов по часовой стрелке
пока впереди под стеной есть клетки
начать цикл
идти вперёд
закрасить клетку
закончить цикл
пока робот напротив стены
начало цикла
повернуться на 90 градусов по часовой стрелке
идти на 1 клетку вперёд
повернуться на 90 градусов по часовой стрелке
пока впереди под стеной есть клетки
начать цикл
идти вперёд
закрасить клетку
закончить цикл
повернуться на 90 градусов против часовой стрелки
идти на 1 клетку вперёд
повернуться на 90 градусов против часовой стрелки
пока впереди под стеной есть клетки
начать цикл
идти вперёд
закрасить клетку
конец цикла
конец цикла
повернуться на 90 градусов по часовой стрелке
пока впереди есть клетки идти вперёд
повернуться на 90 градусов по часовой стрелке
пока впереди есть клетки идти вперёд
повернуться на 90 градусов по часовой стрелке
пока робот не напротив стены идти вперёд;
закрасить клетку
пока робот напротив стены
начало цикла
пока впереди под стеной есть клетки
начать цикл
идти вперёд
закрасить клетку
закончить цикл
повернуться на 90 градусов по часовой стрелке
идти на 1 клетку вперёд
повернуться на 90 градусов по часовой стрелке
пока впереди под стеной есть клетки
начать цикл
идти вперёд
закрасить клетку
конец цикла
повернуться на 90 градусов против часовой стрелки
идти на 1 клетку вперёд
повернуться на 90 градусов против часовой стрелки
пока впереди под стеной есть клетки
начать цикл
идти вперёд
закрасить клетку
конец цикла
конец цикла

в 3-ем могла напутать

Ответить

Другие вопросы из категории

1.Для одновременного запуска сразу нескольких ожидающих потоков используется?

2. Для запуска только одного из нескольких ожидающих потоков используют?
3. Для исключения одновременного доступа к разделенным ресурсам несколькими потоками и без возможности многократной блокировки одним потоком используют?
4. Для одновременного доступа к разделяемому ресурсу заданного количества потоков используют?
5. Для исключения одновременного доступа к разделяемому ресурсу несколькими процессами используют с возможностью многократной блокировки?
Варианты ответов для пятого вопроса!!!
а) событие б) семафор в) мьютекс г) критическая секция д) нет правильно ответа
Варианты ответов для вопросов 1-4:
а) auto reset event b) semaphore c) mutex d) critical section i) manual reset event
Помогите пожалуйста!!!

Клиент открыл счёт в банке 1 марта,вложив 1000 рублей.Каждый месяц размер вклада увеличивается на 2 процента.Определить за какой месяц величина

ежемесячного увеличения вклада превысит 50 рублей.Напишите,пожалуйста,программу.

Составить программу.

Определить кол-во дней между двумя днями одного и того же года (год- от 1900 до 2100).
Входные данные: файл input.txt, содержащий две строки по три числа, записанные через пробелы (дд мм гггг). Даты могут быть записаны не обязательно в порядке возрастания.
Входные данные: файл output.txt, содержащий одно число- кол-во дней между датами.

Читайте также

Помогите пожалуйста! 1)Построить развлетвляющийся алгоритм, записать алгоритмы ввиде блок-схемы и на алгоритмическом языке. Треугольник задан

длинами своих сторон – a, b, c. Определить является ли

он тупоугольным, прямоугольным или остроугольным.

2) Построить циклический алгоритм, записать ввиде блок-схемы и на алгоритмическом языке.

Построить алгоритм, который определяет количество студентов в группе,
чей рост превышает среднее для группы значение.

Помогите, пожалуйста, решить задачу:

Дан вектор из 25 элементов. Найти минимальное значение. Записать на языке Pascal и построить алгоритм.

Найти алгоритм решения задачи и реализовать его с помощью оператора(операторов) if-then-else. В Атлантическом океане терпит бедствие пассажирский теплоход

”Посудина”. Все пассажиры будут спасены, если на помощь успеют два судна. Судно продержится на плаву t часов. Скорость судов-спасателей 40 узлов. Составить программу, определяющую спасутся ли пассажиры. Известны расстояния от трех судов-спасателей до тонущего судна.

Ребята,срочно помогите!)Даю 100 баллов.Составить алгоритм решения задачи на языке C++ . В отчете предоставить три программы с разными операторами

цикла (do ...while, while, for). В алгоритме и программе массивов не использовать.

Я здесь набросал все ,что мог, помогите доработать, написать до конца все эти операторы в одну программу,не получается.

#include <iostream>
#include <cstdlib>
#include <conio.h>
#include <math.h>

using namespace std;
int main()
{
float a,z,xn,xk,dx,R,max,min; float count=0,x;
a = 2.94;xn = 1.5;xk = 5.5;dx = 0.4;
while (xn <= xk)

for (x >= xn; x <= xk; x+=dx, dx = dx + 0.4)
{
do
{
z = a*pow((a*x*x*x*x*x*x*x/cos(a*a*a)+1,31),(1/5));
printf("X = %10f, Z = %10f \n", x, z);
dx = dx + 0.4;
}
while (x <= xk);
return 0;
}
{
max = x;min = z;
if (x > max) max = x;
if (z < max) min = z;
if (count > 2) count = 0;
if (count == 2) printf("X = %10f, Z = %10f \n", x, z);
count=0;
}
cout<<"max="<<max<<"\t min="<<min<<"\n";
cout<<"R="<<min-max<<"\n";
system("PAUSE");
return 0;
}



Вы находитесь на странице вопроса "построить алгоритм трех задач.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.