Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Ребят, помогите решить!

5-9 класс

Дано два натуральных числа N и M.
Написать программу для определения наименьшего из чисел, составленных из цифр данных чисел. Незначащих нулей в найденном числе быть не должно.
Формат входных данных:
Входной файл INPUT.TXT содержит два натуральных числа N (10<=N<=10^100) и M (10<=M<=10^100), разделенных одним пробелом.
Формат выходных данных:
Выходной файл OUTPUT.TXT должен содержать найденной наименьшее число.
Пример
INPUT.txt. OUTPUT.txt
423 42 22344

Olya04 24 марта 2014 г., 3:58:26 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Миллииии
24 марта 2014 г., 5:15:58 (10 лет назад)

procedure ShellStr(var s: string);
{ сортирует символы строки методом Шелла }
var
  i, j, n, step: integer;
  c: char;
begin
  s := Trim(s);
  n := Length(s);
  step := n div 2;
  while step > 0 do
  begin
    for j := n - step downto 1 do
    begin
      i := j;
      while i <= n - step do
      begin
        if s[i] > s[i + step] then
        begin
          c := s[i];
          s[i] := s[i + 1];
          s[i + 1] := c
        end;
        i := i + step
      end
    end;
    step := step div 2
  end
end;

procedure TrimNullsLeft(var s: string);
{ Усекает левые (незначащие нули) в строке s }
var
  i, n: integer;
begin
  i := 1; n := Length(s);
  while (s[i] = '0') do i := i + 1;
  s := Copy(s, i, n - i + 1)
end;

var
  p: integer;
  s, M, N: string;
  f: text;

begin
  Assign(f, 'input.txt');
  Reset(f);
  Readln(f, s);
  Close(f);
  Assign(f, 'output.txt');
  Rewrite(f);
  s := Trim(s);
  p := Pos(' ', s);
  M := Copy(s, 1, p - 1);
  N := Copy(s, p + 1, Length(s) - p);
  s := M + N;
  ShellStr(s);
  TrimNullsLeft(s);
  Writeln(f, s);
  Close(f);
  Writeln('Программа завершила работу')
end.

+ 0 -
VladosMironov
24 марта 2014 г., 7:14:16 (10 лет назад)

Комментарий удален

+ 0 -
Gosha1999rus
24 марта 2014 г., 10:05:48 (10 лет назад)

ЛОГИКА В ТОМ ЧТО НУЖНО ДУМАТЬ, КАК С ПОМОЩЬЮ ПРОГРАММЫ ЭТО СДЕЛАТЬ, В ЖИЗНИ ТАКОЕ ВРЯДЛИ ПРИГОДИТСЯ

+ 0 -
Кс222
24 марта 2014 г., 12:25:54 (10 лет назад)

Комментарий удален

+ 0 -
Maria6Б
24 марта 2014 г., 13:24:05 (10 лет назад)

задание нормальное, всё чётко, а раз ты такой умный то напиши программу

+ 0 -
Iova2013
24 марта 2014 г., 15:54:02 (10 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

Проблема с Паскалем. Мне надо посчитать среднее арифметическое всех отрицательных чисел в массиве из десяти элементов. Я понимаю, как сначала надо

распредилить, какие числа меньше нуля, но как вычислить среднее арифметическое, не зная точное кол-во отрицательных элементов? Желательно написать полной программой. Заранее спасибо с:

Какие бывают виды сканеров?

Читайте также

Ребят помогите решить по машине Поста задачку :) на информационной ленте машины поста расположен "разряженный " массив меток (т.е. метки идут через одну

клетку - есть метка, нет метки, есть, нет и т.д.), заканчивающиеся двумя подряд идущими метками. Каретка находится под крайней левой меткой. Требуется заполнить в этом массиве все пустоты метками.

Помогите решить задачи , Плииииз !!!! 1)Семья , состоящая из дедки , бабки , внучки , жучки , кошки , выращивает репу . Потребуется ли им привлечение

мышки для сбора урожая ИСХОДНЫЕ ДАННЫЕ ______________________ 2)Малыш и карлосон решили по-братски разделить два сладких орешка-болльшой и маленький . Как это сделать ? Помогите плиз , заранее спасибо :) надеюсь на вас ! Просто я непоняла что с исходными данными делать .

PASCAL. нужна помощь. ПОЖАЛУЙСТА помогите решить задачу в PASCAL (если рОЧЕНЬ нужна помощь. ПОЖАЛУЙСТА помогите решить задачу в PASCAL (если решиш - проси

что угодно, помогу)Вот задача - Под конец учебного года ученики 11 класса решали понять у кого же из них будет самый высокий средний балл ? Известно , что - в классе учится 14 учеников, - Сумма всех средних баллов аттестата = 100.Известно также , что первый ученик имел средний балл, который составляет 1/ 12 суммы всех средних баллов. Второй ученик - на 0,15 % больше, чем первый ученик , но на 1,75 % меньше , чем третий ученик . Средние баллы аттестатов двух сестер были равными среднему арефметичному оценок вышеупомянутых учеников , разделенном на 1.5 . Четвертый ученика на конец года имел такой же балл , как и первый ученик , но на 5% меньше , а остальные ученики - имели равные баллы .Какой средний балл на конец года получил каждЫй?

РебяТ помогите очень надо, решит не могу не был на уроках, а она мне дала задачу.

Массив содержит 20 случайных чисел из промежутка [1..37] Выводит на экран эдементы больше 11, но меньше 22 ПОжалуйста помогите)

Пожалуйста,помогите решить задачу по информатике:

Маша набирает текст со скоростью 40 символов в минуту,а Катя- 20 символов в минуту.Через какое время девочки введут одинаковое количество символов,если Катя начала набирать текст на 5 минут раньше?
Нужно решить без x! Спасибо



Вы находитесь на странице вопроса "Ребят, помогите решить!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.