Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Задачи по Паскалю.Условный оператор.

5-9 класс

1.Даны два действительных числа меньшее из них замените полусуммой их, а большее их произведением.
2.Найдите решение уравнения ах+ в=0, если оно существует,если а=0
3.написать программу удвоения меньшего из двух чисел

Sanek305 20 июня 2014 г., 6:40:00 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
JokerStrax
20 июня 2014 г., 8:51:16 (9 лет назад)

1)
program chik2;
var a,b,c:real;
begin
readln(a,b);
if(a<b)then begin
c:=a;
a:=(a+b)/2;
b:=b*c;
end;
if(a>=b)then begin
c:=b;
b:=(a+b)/2;
a:=a*c;
end;
writeln(a,' ',b);
end.
2)
program chik;
var a,x,b:real;
begin
readln(a,b);
if(a=0)and(b<>0)then writeln('НЕТ решений');
if(a<>0)then begin
 x:=-b/a;
writeln(x);
end;
end.
3)

program chik3;
var a,b:real;
begin
readln(a,b);
if(a<b)then a:=a*2 else
if(b<a)then b:=b*2;
writeln(a,' ',b);
end.

Ответить

Другие вопросы из категории

Вопрос

Чем может отличатся один объект от другого или что изменится у объекта при выполнение действия????

Очень срочно. Вопрос от красворда

Читайте также

работа по программированию: "Условный оператор"

Составить блок-схему и программу к задаче:
В компьютер вводят два целых числа. Если а больше b, то вывести сообщение "Наибольшее число="; а иначе вывести сообщение "Наибольшее число="; b

Дан условный оператор:

if a<5 then c:=1

else if a>5 then c:=2
else c:=3

какое значение имеет переменная a, если в результате выполнения условного оператора переменной c присваиваетсязначение 3?

надо решить задачу по паскалю) "Чтобы избавиться от простуды необходимо 20 таблеток колдрекса или 30 таблеток аспирина. Сколько порций эскимо можно

купить на эти деньги?"
напишите пожалуйста как составить это в паскале) буду благодарна:)

Дан условный оператор:

if a<5 then c:=1
else if a>5 then c:=2
else c:=3
Какое значение имеет переменная a , если в результате выполнения условного оператора переменной c присваивается значение 3?



Вы находитесь на странице вопроса "Задачи по Паскалю.Условный оператор.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.