Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Сформируйте одномерный массив из 4 элементов ( значения элементов зависит от порядкового номера массива и вычисляется по формуле i^2) . Вычислить сумму

10-11 класс

значений элементов одномерного массива.

Fekdhfnx 15 янв. 2017 г., 9:58:51 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
VlaDNaMe
15 янв. 2017 г., 11:10:41 (7 лет назад)

Program Zadacha;
Var a: Array [1..4] of Integer;
sum, i: Integer;
Begin
For i := 1 To 4 Do
Begin
a[i] := i * 2;
sum := sum + a[i];
End;
WriteLn('Сумма: ', sum);
ReadLn;
End.

+ 0 -
Kievleanka
15 янв. 2017 г., 13:26:02 (7 лет назад)

const n = 4;
var
  a: Array [1..n] of Integer;
  sum, i: Integer;

begin
  for i := 1 To n Do begin
    a[i] := i * i;
    sum := sum + a[i];
  end;
  WriteLn(sum);
end.

Ответить

Другие вопросы из категории

Читайте также

1.В произвольно заданном одномерном массиве ( случайные значения из отрезка -6 до 11 ) из 6 элементов, определить количество отрицательных, нулевых и

положитльных элементов.
2.
Сформируйте одномерный массив из 5 элементов (значения элементов укажт пользователь с клавиатуры). Обнулите значения всех элементов с нечетными индексами. Выведите значения одномерного массива в строку через пробел.

1)дан одномерный массив из 5 элементов.найти сумму положительных элементов. 2)Дан одномерный массив из 7

элементов.Найти колличество четных положительных элементов.

3)Дан массив из 6 элементов.Найти произвдение положительных из них.

ЛЮДИ, ПОМОГИТЕ, ПОЖАЛУЙСТА Сформировать одномерный массив из 20 элементов (значения элементов задаются случайным образом). Вывести массива на

экран. Найти среднее арифметическое элементов первой половины массива и сумму элементов второй половины массива.

паскаль массивы

ПАСКАЛЬ.1)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 1000.опишите на русском языке или на одном из

языков программирования алгоритм,позволяющий найти среднее арифметическое нечетных трехзначных чисел,записанных в этом массиве.если ни одного такого числа нет,нужно вывести сообщение об этом.
2)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 100.опишите на русском языке или на одном из языков программирования алгоритм,позволяющий найти и вывести произведение элементов массива,которые имеют четное значение и не оканчиваются на 0.

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива



Вы находитесь на странице вопроса "Сформируйте одномерный массив из 4 элементов ( значения элементов зависит от порядкового номера массива и вычисляется по формуле i^2) . Вычислить сумму", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.