Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Program primer_1;

10-11 класс

var v,a,b,c,r,h:real;
var num:integer;
begin
writeln('Введите значение num');
writeln('num='); readln(num);
case num of
1: writeln('Введите значения a,b,c');
write('a='); readln(a);
write('b='); readln(b);
write('c='); readln(c);
v:=a*b*c;
writeln('v=',v:8:3);
2: write('Bвежите значения r');
write('r='); readln(r);
v:=4/3*pi*power(r;3);
writeln('v=',v:8:3);
3: write('Введите значения r,h');
write('r='); readln(r);
write('h='); readln(h);
v:=1/3*pi*sqr(r)*h;
wrireln('v=',v:8:3);
else write(‘Введено число вне диапазона 1-3!’);
end.

пытаюсь написать программу в которой от того какую цифру из трех ты выберешь будет зависеть объем какой из трех фигур надо будет найти. Вижу что ошибка в использовании оператора case, как будто нельзя писать какие-то другие действия кроме write после 1: 2: 3:

Карина12343 19 февр. 2017 г., 9:18:44 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Okcankoc
19 февр. 2017 г., 11:28:02 (7 лет назад)

Кажется понял в чем проблема.У вас не работало т,к, отсутствовали begin и end; в case .Плюс еще пару недочетов в коде

+ 0 -
Tanyagum00
19 февр. 2017 г., 12:37:19 (7 лет назад)

В паскале с оператором case плохо знаком,но все же,если он выдает ошибку ,что вам мешает ввести все переменные до оператора case?А в самом операторе только присваивать.И вконце вывести.

+ 0 -
Odilkot
19 февр. 2017 г., 13:16:53 (7 лет назад)

а как же он будет определять какой из объемов к чему относится?

+ 0 -
Lyusikz
19 февр. 2017 г., 14:46:18 (7 лет назад)

в лс напишу

+ 0 -
Ollegro
19 февр. 2017 г., 17:24:11 (7 лет назад)

В классическом Паскале нет функции power )) Нет его и в ТурбоПаскаль и в БорландПаскале даже. В Delphi и Pascal.ABC есть. Во Free Pascal - не помню...

+ 0 -
Matsievaamina
19 февр. 2017 г., 19:08:46 (7 лет назад)

А так, по программе - Вы не заключили каждую группу операторов под case в операторные скобки begin .. end

Ответить

Другие вопросы из категории

Помогите пожалуйста срочно надо ?

1 Кбайт=.........байт = ........ бит
7 Кбайт=......... байт = ........ бит
15 Кбайт =........байт = ......бит

Найти формулу данной функции

Читайте также

Если в прямоугольной матрице меньше половины столбцов содержит отрицательные элементы, то все элементы с нечетными номерами столбцов умножить на 10. В

противном случае все отрицательные элементы матрицы возвести в квадрат.

У меня получилось вот что:

program s455;
uses crt;
const
m=10;
n=12;
Var
A: array[1..m,1..n] of integer;
i, j, k, s: integer;

Begin
writeln('Enter size');
readln;
s:=0;
for j:=1 to m do
begin
k:=0;
for i:=1 to n do
end;
begin
if a<0 then begin
k:=1;
end;
if k=1 then s:=s+1;
end;
begin;
if k<0
then a[i, j]:=a[i, j*2-1]*10;
else a[i, j]:=a[i, j]*c [i, j]
end;
writeln

Не могу понять в чем ошибка

program klass; type ocenki=record name:string[15]; marks: array [1..5] of integer; end; var a,k,i:integer;

c:array [1..5] of ocenki;

begin k:=0;

For i:=1 to 5 do

With c[i] do

begin

write('vvedite name'); readln(name);

write('vvedine marks');

for i:=1 to 5 do read(marks[i]);

a:=i;

if c[a].marks < 2 (вот здесь выдает что операнды имеют неприводимые типы) then k:=k+1; writeln(k);

end;

end.

(Подскажите пожалуйста где допустила ошибку)

Какая тут ошибка, посмотрите, пожалуйста program znacheniya uglov; uses crt; var x: integer; begin writeln('wedite znachenie gradusnoi mery ugla');

read(x); if a=180 then writeln('razvernutyi') else writeln ('ne razvernutyi'); end.

Помогите исправить ошибки и написать блок-схему. Задание: Имеется массив А из N произвольных чисел, среди которых есть положительные,

отрицательные и равные нулю. Используя оператор цикла, составить программу, вычислить количество положительных и нулевых и сумму отрицательных.

Листинг программы:

Program Massiv;

Const n=10;

Var A:array [1..4] of integer;

I, c, c2, c3: integer;

Begin

For i=1 to N do begin

Readln (a[i]); If (a[i]=0 then inc(c)

Else if ([ai]<0) then inc(c2)

Else inc (c3);

End;

Writeln (`нулевые:`,c);

Writeln (`отрицательные:`,c2);

Writeln (`положительные:`,c3);

End.

program vst; var

c:



Вы находитесь на странице вопроса "Program primer_1;", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.