Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Решите пожалуйста программу в паскале:Составить программу, которая формирует массив из 10 случайных чисел от -30 до 30 и если третий элемент больше нуля,

5-9 класс

то поменять местами третий и пятый элементы, если третий элемент равен нулю, то увеличить оба эти элементы в 2 раза, иначе третий и пятый элементы сохраняют прежние значения.

PositiveCat 15 мая 2013 г., 8:58:29 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
DashaKazakstan
15 мая 2013 г., 10:27:05 (10 лет назад)

program pr;
var 
a: array [1..10] of integer;
i, m: integer;
begin
for i:= 1 to 10 do
a[i]:=-30+ random(30+30+1);

for i:=1 to 10 do 
write(a[i]:5);

if a[3]>0 then begin
                    m:= a[3];
                    a[3]:=a[5];
                    a[5]:=m;
                    end;
if a[3]=0 then begin
                    a[3]:=a[3]*2;
                    a[5]:=a[5]*2;
                    end;
for i:= 1 to 10 do
write ( a[i]:5);
end.

Ответить

Читайте также



Вы находитесь на странице вопроса "Решите пожалуйста программу в паскале:Составить программу, которая формирует массив из 10 случайных чисел от -30 до 30 и если третий элемент больше нуля,", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.