Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Напишите программу, которая определяет, есть ли среди цифр введенного с клавиатуры целого трехзначного числа одинаковые.

10-11 класс

Valyapro 08 окт. 2014 г., 8:48:42 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Jampik1998
08 окт. 2014 г., 10:11:40 (9 лет назад)

В две фотографии не вместилось
этоодна фотка и одна программа

+ 0 -
Tomszhanna
08 окт. 2014 г., 10:58:28 (9 лет назад)

1. Переменные n1,n2,n3 — для цифр числа

Ответить

Другие вопросы из категории

Распишите решение и дано, пожалуйста

В коробке лежат кубики:10 красных,8 зеленых,5 желтых,12 синих.Вычислите вероятность доставания кубика каждого цвета и кол-ва информации при этом будет получен.

ДАМ 50 БАЛЛОВ, СРОЧНО!

5 и 6 задания

Важнейшей характеристикой, определяющей быстродействие процессора, является?

1) Тактовая частота
2) размер БИС
3) Год изготовления
4) Все варианты ответов верны.

1.пользователь вводит натуральное число. Определить среднее арифметическое цифр этого числа.

2.пользователь вводит натуральное число N. Найти сумму всех натуральных чисел от 1 до N.

Читайте также

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.

1.Напишите программу, которая в последовательности натуральных чисел

определяет количество чисел, кратных 4. Программа получает на вход
количество чисел в последовательности, а затем сами числа. В
последовательности всегда имеется число, кратное 4. Количество чисел не
превышает 1000. Введённые числа не превышают 30 000. Программа должна
вывести одно число — количество чисел, кратных 4.

2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 1000. Введённые числа не превыша ют 30 000. Программа должна вывести одно число — минимальное число, кратное 3.

№1

Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел а и Ь хотя бы одно четное. Была написана следующая программа:

•​ var a, b: integer;

•​ begin

•​ readln(a, b);

•​ a := a mod 2;

•​ if a > 0 then b := b mod 2;

•​ if b > 0 then

•​ writeln ('четных чисел нет')

•​ else

•​ writeln ('четное число есть');

•​ end.

Доработайте эту программу таким образом, чтобы задача решалась верно.

№2

С клавиатуры вводится трёхзначное число. Нужно вывести ответ «Да», если все его цифры четные, и ответ «Нет» в остальных случаях. Если введено не трёхзначное число, должно быть выведено сообщение «Неверное число».

№1

Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел а и Ь хотя бы одно четное. Была написана следующая программа:

•​ var a, b: integer;

•​ begin

•​ readln(a, b);

•​ a := a mod 2;

•​ if a > 0 then b := b mod 2;

•​ if b > 0 then

•​ writeln ('четных чисел нет')

•​ else

•​ writeln ('четное число есть');

•​ end.

Доработайте эту программу таким образом, чтобы задача решалась верно.

№2

С клавиатуры вводится трёхзначное число. Нужно вывести ответ «Да», если все его цифры четные, и ответ «Нет» в остальных случаях. Если введено не трёхзначное число, должно быть выведено сообщение «Неверное число».

1)Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру.

2)Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
3)Напишите программу, которая выводит в одну строчку все делители переданного ей числа, разделяя их пробелами.
4)Напишите программу, которая выводит в столбик цифры введённого числа, начиная с первой. Используйте процедуру.



Вы находитесь на странице вопроса "Напишите программу, которая определяет, есть ли среди цифр введенного с клавиатуры целого трехзначного числа одинаковые.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.