Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Cоставить программу на языке программирования, осуществляющую сортировку значений трех переменных А, В, С по возрастанию. Проверить программу

5-9 класс

на тестах при разных вариантах значений исходных данных.

Btulepova 11 марта 2017 г., 5:30:58 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
коляно
11 марта 2017 г., 6:45:18 (7 лет назад)

procedure abc(var a,b:real);
var x:real;
begin
x:=a;
a:=b;
b:=x;
end;
var a,b,c:real;
begin
writeln('Vvedite a,b,c');
readln(a,b,c);
if a>b then abc(a,b);
if b>c then abc(b,c);
if a>b then abc(a,b);
write(a,' ',b,' ',c);
end.

Ответить

Другие вопросы из категории

Помогите срочно!!!!!!!!!!!!

2.Эволюция графического редактора – начиная от самого простого (например, Paint) до профессионального (например, Photoshop) и объяснить, как развивались программы, для каких задач нужна каждая из них и каковы их особенности.
Даю 30 баллов.

Вычеслите сколько байтов занимает на CD одна минута стереозаписи( частота

дискретизации- 44000, разрядность – 16 битов). Какова максимальная
продолжительность стереозаписи на диске емкостью 700Мбайт?

Что означают эти ярлыки? СРОЧНО

Читайте также

1.Какое значение переменной S будет напечатано после выполнения фрагмента программы,записанной на языке программирования TURBO PASCAL:A:=2В: = 3;

if A>B then S: = A+B;
writeln (S);
Варианты ответов:1)5 ;2)6; 3)7; 4)8

2. Какое значение переменной S будет напечатано после выполнения фрагмента программы, записанной на языке программирования PASCAL:
S: =1;
N: =1;
while N<=3 do
begin
S: = S*N;
N: = N+1;
end;
writeln(S);
Варианты ответов: 1)2 ; 2)1; 3)0; 4)4

из математической записи создать запись на языке программирования.

а)2,136+2/3y
б)(x-5)+a/3ax
Например:
Математическая запись: Запись на языке программирования:
a+3b-2c (a+3 умножить на b-2 умножить на c):(7 умножить на a+2)
Срочно!

Помогите с информатикой! Нужно cоставить программу на языке программирования (Паскаль) с ветвлением

ЗАДАЧА - Составить программу решения задачи: Z = m/(m-1)
ЗАДАЧА - Составить программу определения четных (нечетных) чисел



Написать программу на языке программирования Pascal.

Перевод дюймов в сантиметры (1дюйм=2,54см). Нужно, чтобы при запуске программы на экране выходило в два столбика дюймы и сколько это будет сантиметров. До 20 чисел. Через оператор While.



Вы находитесь на странице вопроса "Cоставить программу на языке программирования, осуществляющую сортировку значений трех переменных А, В, С по возрастанию. Проверить программу", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.