Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

TURBO Pascal

10-11 класс

var
i,N:integer;
begin
writeln('Vvedite N');
readln(N);
for i:=1 to n do
if (i mod 2<>0)and(i mod 3<>0)and(i mod 5<>0)then writeln(i);
readln
end.

Данная программа выдает все числа, от 1 до заданного (n), которые не делятся без остатка на 2,3,5. что нужно исправить, чтобы программа выдавала только количество этих чисел.
Заранее спасибо.

Помыслы 11 мая 2014 г., 5:12:18 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vampirkaq
11 мая 2014 г., 7:02:27 (10 лет назад)

Заведи переменную счетчика, например kol

if (i mod 2<>0)and(i mod 3<>0)and(i mod 5<>0)then

+ 0 -
Arisshhka
11 мая 2014 г., 9:19:04 (10 лет назад)

Спасибо

+ 0 -
еджюпеик
11 мая 2014 г., 11:24:27 (10 лет назад)

Вопрос закрыт

Ответить

Другие вопросы из категории

помогите бестрей плиз 8 класс!!
Написать программу на паскале по такому вот вопросу:

"Вводиться 3 числа. Есть ли вероятность того, что одно из них оканчивается на 0?"

1.Сколько секунд потребуется обычному модему,

передающему сообщения со скоростью 28800 бит/с, чтобы передать цветное растровое изображение размером 640Х480
пикселей при условии, что цвет каждого
пикселя кодируется тремя битами?

Читайте также

Turbo Pascal

Задание1.Вычислить заданное выражение для данных a, b используя оператор IF. Результат Х – введите вещественный тип данных

a*b-1,если a>b,
(a-5)/b,если a>b
X=
Задание 2. Вычислить заданное выражение для данных a, b используя, оператор

Написать программу проверки знания истории архитектуры. Программа должна вывести вопроси три варианта ответа. Пользователь должен выбрать

правильный ответ и ввести его номер.Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом).
Архитектор Исаакиевского собора:
1. Доменико Трезини
2. Огюст Монферран
3. Карл Росси
Введите номер правильного ответа и нажмите <Enter>
= 2
Правильно.
Архитектор Исаакиевского собора - Огюст Монферран

на языке Turbo Pascal

Составить программу Плиз, в среде PASCAL ABC (TURBO PASCAL) выполняющую вычисления по формуле:

y=2ctg3x-
распешите все действия что писать плиз.



Вы находитесь на странице вопроса "TURBO Pascal", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.