Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Удвоить трѐхзначное число, введенное с клавиатуры, если оно содержит в своей записи хотя бы одну единицу, и возвести в квадрат в другом случае.

10-11 класс

Если введѐнное число не трѐхзначное, вывести сообщение об ошибке.(В ПАСКАЛЕ)

Atomickiten 10 нояб. 2013 г., 1:53:16 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Анкей
10 нояб. 2013 г., 3:04:44 (10 лет назад)

program test;

var
    num, n : longint;
    i : integer;
    f : boolean;

begin
    readln(num);
    n := num;
    f := false;
    i := 0;
    repeat
        if n mod 10 = 1 then
            f := true;
        n := n div 10;
        i := i + 1;
    until n = 0;
    if i <> 3 then begin
        Writeln('Chislo ne treh-znachnoe.');
    end
    else begin
        if f then
            num := num * 2
        else begin
            num := sqr(num); end;
        writeln('Rezultat: ', num)
    end;
end.

Ответить

Другие вопросы из категории

Мне нужен рисунок для pascal ABС,рисунок должен быть большой.

Только не граффический!

Вычислите сумму чисел x и y,

при x = A116, y = 11012. Результат представьте в
десятичной системе счисления.

Читайте также

Написать на языке паскаль:

Умножить трехзначное число, введенное с клавиатуры на 2, если оно содержит в своей записи хотя бы одну единицу.

1) Написать программу для вычисления суммы цифр пятизначного числа , введенного с клавиатура

2) Заданы действительные числа a , b , c и d . Написать программу нахождения полусуммы наименьшего и наибольшего из них.
3) Написать программу для вычисления суммы цифр числа , введенного с клавиатуры

Помогите прошу

№1

Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел а и Ь хотя бы одно четное. Была написана следующая программа:

•​ var a, b: integer;

•​ begin

•​ readln(a, b);

•​ a := a mod 2;

•​ if a > 0 then b := b mod 2;

•​ if b > 0 then

•​ writeln ('четных чисел нет')

•​ else

•​ writeln ('четное число есть');

•​ end.

Доработайте эту программу таким образом, чтобы задача решалась верно.

№2

С клавиатуры вводится трёхзначное число. Нужно вывести ответ «Да», если все его цифры четные, и ответ «Нет» в остальных случаях. Если введено не трёхзначное число, должно быть выведено сообщение «Неверное число».

№1

Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел а и Ь хотя бы одно четное. Была написана следующая программа:

•​ var a, b: integer;

•​ begin

•​ readln(a, b);

•​ a := a mod 2;

•​ if a > 0 then b := b mod 2;

•​ if b > 0 then

•​ writeln ('четных чисел нет')

•​ else

•​ writeln ('четное число есть');

•​ end.

Доработайте эту программу таким образом, чтобы задача решалась верно.

№2

С клавиатуры вводится трёхзначное число. Нужно вывести ответ «Да», если все его цифры четные, и ответ «Нет» в остальных случаях. Если введено не трёхзначное число, должно быть выведено сообщение «Неверное число».



Вы находитесь на странице вопроса "Удвоить трѐхзначное число, введенное с клавиатуры, если оно содержит в своей записи хотя бы одну единицу, и возвести в квадрат в другом случае.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.