Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Решить задачу в паскаль. Составить блок схему.

10-11 класс

Заданы два массива. Создать один массив в котором все элементы расположены в порядке возрастания.

Wwwnastua 11 авг. 2016 г., 13:17:52 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Marinarekshins
11 авг. 2016 г., 15:25:11 (7 лет назад)

const
    m = 10; 
var
    a,b: array[1..m] of integer;
    c: array[1..m*2] of integer;
    i, j, k: integer; 
begin     
write ('Первый массив: ');   
for i := 1 to m do
  begin
  a[i] := random(100);
  c[i]:=a[i];
  write (a[i],'; ');
  end;   
writeln;      
write ('Второй массив: ');   
for i := 1 to m do
  begin
  b[i] := random(100);
  c[i+m]:=b[i];
  write (b[i],'; ');
  end;   
writeln;     
for i := 1 to 2*m-1 do
        for j := 1 to 2*m-i do
           if c[j] > c[j+1] then
             begin
             k := c[j];
             c[j] := c[j+1];
             c[j+1] := k
             end;    
write ('Отсортированный третий массив: ');   
for i := 1 to 2*m do
   write (c[i],'; ');
end.

Ответить

Другие вопросы из категории

Program lab1;var

x,y:real;
begin
writeln('введите x');
readln(x);
begin
if (abs(x)<=1) then
y:=sqr(x)-1;

else
if(abs(x)>1) and (abs(x)<=2)
then
y:=2*x-1;
else
if (abs(x)>2) then
y:=exp(5*ln(x))-1;
end;
writeln ('y=',y);
End.


где ошибка в программе? пишет: : Встречено 'else', а ожидался оператор. Нужно найти у, при определенных значениях х.

1) Какой объем памяти занимает один кадр на MacBook Pro Retina, если плотность точек равна 220 ppi (пикселей на дюйм), диагональ 15.4 дюймов, соотношение с

торон 16:10, а глубина цвета – 24 бит.
2) Перевести темно-голубой (0, 152, 220) из RGB в HSB, умень-шить яркость в 2 раза и перевести обратно.
3) Сравните размер изображения одного, а лучше всех из пере-численных форматов с размером, который оно должно занимать, если хранить его без сжатия. Запишите степени сжатия по сравнению с не сжатым файлом.

Убедительная просьба писать подробнее и желательно до 24 июня. Заранее благодарю.

Читайте также

Нужно составить блок-схему алгоритма подготовки к сдаче к экзамену.

Я не могу сочинить этот "алгоритм", помогите ;)
Блок-схемы строить не надо, просто описать, что надо делать.

1)составить блок-схему поиска двузначных чисел,таких,что если к сумме цифр этого числа прибавить квадрат этой суммы,то получится это число.

2)построить блок схему которая меняет порядок цифр числа на обратный. например было 12345,стало 54321.

СРОЧНО!!!!!!!!!!!!!!!!!!Написать программу в паскале + составить блок-схемы:

4)Если целое M делится на целое число NБ то на экран выводится частное от деления,в противном случае выводится сообщение"M на N нацело не делится".
8)Одинаковы ли цифры данного двухзначного числа.
9)является ли сумма цифр двухзначного числа четной.
12)кратна ли числу A сумма цифр двухзначного числа.
14)какая из цифр трехзначного числа больше: первая или вторая.
16) все ли цифры трехзначного числа одинаковые.

помогите пожалуйста решить задачу по информатике!!!

в заповедник выпустили z зверей. за год количество особей увличивается на определенный процент. Сколько зврей будет через определенное время?
1. условие задачи
2. математическая модель
3. список переменных с их расшифровкой
4. блок- схема алгоритма
5. программный код



Вы находитесь на странице вопроса "Решить задачу в паскаль. Составить блок схему.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.