Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

помогите пожалуйста написать программу на паскале,определяющую является ли матрица магическим квадратом.

5-9 класс

Elusive1997 02 янв. 2014 г., 12:42:04 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
анна333333
02 янв. 2014 г., 14:30:13 (10 лет назад)

const n = 5;
          m = 5;
var
  a: array[1..n, 1..m] of integer;
  i, j, tmp, s_s: integer;
  magic: boolean;
begin
  magic := true;
  for i := 1 to n do begin
    for j := 1 to m do begin
      a[i, j] := random(50);
      write(a[i, j]:4);
      if(i = 1) then s_s := s_s + a[i, j];
      if(j mod m = 0) then writeln;
    end;
  end;

  for i := 2 to n do begin
    tmp := 0;
    for j := 1 to m do begin
      tmp := tmp + a[i, j];
    end;
    if(tmp <> s_s) then begin
      magic := false;
      break;
    end;
  end;


  for i := 1 to n do begin
    tmp := 0;
    for j := 1 to m do begin
      tmp := tmp + a[j, i];
    end;
    if(tmp <> s_s) then begin
      magic := false;
      break;
    end;
  end;
  if(magic) then writeln('Матрица является магическим квадратом') else
    writeln('Матрица не является магическим квадратом');
end.

Ответить

Другие вопросы из категории

Дан целочисленный

двумерный массив 6x10. Опишите на
русском языке и на языке программирования Паскаль алгоритм вычисления
произведения минимальных элементов из каждой строки. Напечатать значение этого произведения.
Предполагается, что в каждой строке минимальный элемент единственный.

Решите задачу, использую круги Эйлера или схему состава.

В летнем лагере отдыхало 86 семиклассников. 8 из них не любят играть в компьютерные игры. 54 семиклассника предпочитают квесты, 62 - симуляторы. Сколько ребят с одинаковым удовольствием играют и в квесты, и в симуляторы?

Могут ли существовать

Читайте также

Помогите,пожалуйста,написать программу по информатике.Вот такое условие:

Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет:
1). сумму чисел, не превышающих 10;
2). сумму чисел,кратных 3. Помогите пожалуйста,написать эту программу на PaskalABC.

Помогите, пожалуйста, написать программу на Паскале.

Дана строка. Верно ли, что второе слово начинается на ту же букву, которой заканчивается третье слово?

Составить программу, определяющую, является ли данное утверждение истинным:Двузначное число А начинается на 3

Составить программу, определяющую, является ли данное утверждение истинным:Ровно одно из чисел А и В не превышает 100

Помогите, пожалуйста, написать программу в Паскаль

Если дано трехзначное число, например 123 его можно представить в виде 3+2*10+1*10*10. Воспользовавшись этой информацией, создайте программу, которая, получая от пользователя трехзначное число, будет определять из каких цифр оно состоит и выводить их через пробел (например, 1_2_3).



Вы находитесь на странице вопроса "помогите пожалуйста написать программу на паскале,определяющую является ли матрица магическим квадратом.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.